summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:20:37 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:44 +0100
commit9a104547c872de50d762335b30b2f6065a9043d8 (patch)
treedf2a923ef4a4de17321639c264e3814a4eb60c8d /dev-haskell/nats/nats-1.1.2.ebuild
parentdev-haskell/contravariant: bump up to 1.5.2 (diff)
downloadgentoo-9a104547c872de50d762335b30b2f6065a9043d8.tar.gz
gentoo-9a104547c872de50d762335b30b2f6065a9043d8.tar.bz2
gentoo-9a104547c872de50d762335b30b2f6065a9043d8.zip
dev-haskell/nats: bump up to 1.1.2
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/nats/nats-1.1.2.ebuild')
-rw-r--r--dev-haskell/nats/nats-1.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/nats/nats-1.1.2.ebuild b/dev-haskell/nats/nats-1.1.2.ebuild
new file mode 100644
index 000000000000..0ffa621e1a6a
--- /dev/null
+++ b/dev-haskell/nats/nats-1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="lib profile"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Natural numbers"
+HOMEPAGE="https://github.com/ekmett/nats/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+binary +hashable +template-haskell"
+
+RESTRICT=test # avoid circular dep: nats[hashable]->hashable[test]->quickcheck->nats
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ binary? ( >=dev-haskell/binary-0.2:=[profile?] <dev-haskell/binary-0.9:=[profile?] )
+ hashable? ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag binary binary) \
+ $(cabal_flag hashable hashable) \
+ $(cabal_flag template-haskell template-haskell)
+}