summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:12:18 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:43 +0100
commitdb7a83525d65a08c8a92b568ab71c33db5adf3dd (patch)
tree5c25e44d2c04e0fb0d8d36348e3b5e75ab3bca58 /dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild
parentdev-haskell/hs-bibutils: bump up to 6.8.0.0 (diff)
downloadgentoo-db7a83525d65a08c8a92b568ab71c33db5adf3dd.tar.gz
gentoo-db7a83525d65a08c8a92b568ab71c33db5adf3dd.tar.bz2
gentoo-db7a83525d65a08c8a92b568ab71c33db5adf3dd.zip
dev-haskell/pandoc-citeproc: bump up to 0.17.0.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild')
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild
new file mode 100644
index 000000000000..7c28423ccd3e
--- /dev/null
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.17.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+#hackport: flags: -small_base,-test_citeproc
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Supports using pandoc with citeproc"
+HOMEPAGE="https://github.com/jgm/pandoc-citeproc"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils debug embed-data-files static unicode-collation"
+
+RESTRICT=test # fails
+
+RDEPEND=">=app-text/pandoc-2.8:=[profile?] <app-text/pandoc-2.11:=[profile?]
+ >=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-1.6:=[profile?]
+ >=dev-haskell/aeson-pretty-0.8:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/base-compat-0.9:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/hsyaml-0.2:=[profile?] <dev-haskell/hsyaml-0.3:=[profile?]
+ >=dev-haskell/hsyaml-aeson-0.2:=[profile?] <dev-haskell/hsyaml-aeson-0.3:=[profile?]
+ dev-haskell/libyaml:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ <dev-haskell/network-3.2:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/pandoc-types-1.20:=[profile?] <dev-haskell/pandoc-types-1.22:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/safe:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/setenv-0.1:=[profile?] <dev-haskell/setenv-0.2:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/tagsoup:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-haskell/yaml-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ bibutils? ( >=dev-haskell/hs-bibutils-6.4:=[profile?] )
+ debug? ( dev-haskell/pretty-show:=[profile?] )
+ embed-data-files? ( >=dev-haskell/file-embed-0.0:=[profile?] <dev-haskell/file-embed-0.1:=[profile?] )
+ unicode-collation? ( dev-haskell/text-icu:=[profile?] )
+ !unicode-collation? ( dev-haskell/rfc5051:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( >=dev-haskell/temporary-1.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bibutils bibutils) \
+ $(cabal_flag debug debug) \
+ $(cabal_flag embed-data-files embed_data_files) \
+ --flag=-small_base \
+ $(cabal_flag static static) \
+ --flag=-test_citeproc \
+ $(cabal_flag unicode-collation unicode_collation)
+}