summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 08:43:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:57 +0000
commit9096251b2018b7f80ec35f88818456e6d8fae425 (patch)
treeb1f9fd0da6bdae02ae1ed9be7c5084a4e80c8a64 /dev-haskell/persistent/persistent-2.6-r1.ebuild
parentdev-haskell/http-api-data: new package, a depend of dev-haskell/persistent-2.6 (diff)
downloadgentoo-9096251b2018b7f80ec35f88818456e6d8fae425.tar.gz
gentoo-9096251b2018b7f80ec35f88818456e6d8fae425.tar.bz2
gentoo-9096251b2018b7f80ec35f88818456e6d8fae425.zip
dev-haskell/persistent: bump up to 2.6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/persistent/persistent-2.6-r1.ebuild')
-rw-r--r--dev-haskell/persistent/persistent-2.6-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/persistent/persistent-2.6-r1.ebuild b/dev-haskell/persistent/persistent-2.6-r1.ebuild
new file mode 100644
index 000000000000..fc5e14976764
--- /dev/null
+++ b/dev-haskell/persistent/persistent-2.6-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Type-safe, multi-backend data serialization"
+HOMEPAGE="http://www.yesodweb.com/book/persistent"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="nooverlap"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?]
+ >=dev-haskell/fast-logger-2.1:=[profile?]
+ >=dev-haskell/http-api-data-0.2:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/monad-logger-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/path-pieces-0.1:=[profile?]
+ >=dev-haskell/resource-pool-0.2.2.0:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/silently:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.3
+ >=dev-haskell/http-api-data-0.2 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'http-api-data >= 0.2 && < 0.3' 'http-api-data >= 0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag nooverlap nooverlap)
+}