summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:28 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:03 +0100
commit5a323644a191e0b928102dfc83b15219cc5ba63a (patch)
tree007640eb7b4f4184bd97fb6666721fb66bf09acd /dev-haskell/rio/rio-0.1.22.0-r1.ebuild
parentdev-haskell/retry: add 0.9.3.1 (diff)
downloadgentoo-5a323644a191e0b928102dfc83b15219cc5ba63a.tar.gz
gentoo-5a323644a191e0b928102dfc83b15219cc5ba63a.tar.bz2
gentoo-5a323644a191e0b928102dfc83b15219cc5ba63a.zip
dev-haskell/rio: add 0.1.22.0-r1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/rio/rio-0.1.22.0-r1.ebuild')
-rw-r--r--dev-haskell/rio/rio-0.1.22.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/rio/rio-0.1.22.0-r1.ebuild b/dev-haskell/rio/rio-0.1.22.0-r1.ebuild
new file mode 100644
index 000000000000..4e9a92cd357c
--- /dev/null
+++ b/dev-haskell/rio/rio-0.1.22.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A standard library for Haskell"
+HOMEPAGE="https://github.com/commercialhaskell/rio#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/microlens:=[profile?]
+ dev-haskell/microlens-mtl:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/typed-process-0.2.5.0:=[profile?]
+ >=dev-haskell/unliftio-0.2.14:=[profile?]
+ dev-haskell/unliftio-core:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? (
+ dev-haskell/hspec
+ dev-haskell/quickcheck
+ )
+"