summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-31 07:38:01 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:39 +0100
commit6ac63ca1a02c9f940e53373bba08994dbd0c2810 (patch)
treeae8a0c3e9365a9ba8ba3642f249bb8436125a46e /dev-haskell/sandi/sandi-0.5.ebuild
parentdev-haskell/aeson-compat: bump up to 0.3.9 (diff)
downloadgentoo-6ac63ca1a02c9f940e53373bba08994dbd0c2810.tar.gz
gentoo-6ac63ca1a02c9f940e53373bba08994dbd0c2810.tar.bz2
gentoo-6ac63ca1a02c9f940e53373bba08994dbd0c2810.zip
dev-haskell/sandi: bump up to 0.5
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/sandi/sandi-0.5.ebuild')
-rw-r--r--dev-haskell/sandi/sandi-0.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/sandi/sandi-0.5.ebuild b/dev-haskell/sandi/sandi-0.5.ebuild
new file mode 100644
index 000000000000..c432eafc7d45
--- /dev/null
+++ b/dev-haskell/sandi/sandi-0.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: with-conduit:conduit
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://hackage.haskell.org/package/sandi"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conduit"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ conduit? ( >=dev-haskell/conduit-1.3:=[profile?]
+ dev-haskell/exceptions:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.12
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/tasty-th )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit with-conduit)
+}