summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:07:38 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit7ba6c684281afef8cdf5030afe42cee27540aead (patch)
treeefcbf3e3dff360cc9732d5b647855968b50fdb9c /dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
parentdev-haskell/setlocale: allow ghc-8.0 (diff)
downloadgentoo-7ba6c684281afef8cdf5030afe42cee27540aead.tar.gz
gentoo-7ba6c684281afef8cdf5030afe42cee27540aead.tar.bz2
gentoo-7ba6c684281afef8cdf5030afe42cee27540aead.zip
dev-haskell/shakespeare: bump up to 2.0.7
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/shakespeare/shakespeare-2.0.7.ebuild')
-rw-r--r--dev-haskell/shakespeare/shakespeare-2.0.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild b/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
new file mode 100644
index 000000000000..674e23ffb12d
--- /dev/null
+++ b/dev-haskell/shakespeare/shakespeare-2.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A toolkit for making compile-time interpolated templates"
+HOMEPAGE="http://www.yesodweb.com/book/shakespearean-templates"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test_coffee test_export test_roy"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/blaze-html:=[profile?]
+ dev-haskell/blaze-markup:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/parsec-2:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test_coffee test_coffee) \
+ $(cabal_flag test_export test_export) \
+ $(cabal_flag test_roy test_roy)
+}