summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/shellish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/shellish')
-rw-r--r--dev-haskell/shellish/Manifest1
-rw-r--r--dev-haskell/shellish/metadata.xml18
-rw-r--r--dev-haskell/shellish/shellish-0.1.4.ebuild26
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/shellish/Manifest b/dev-haskell/shellish/Manifest
new file mode 100644
index 000000000000..08e167fc05c2
--- /dev/null
+++ b/dev-haskell/shellish/Manifest
@@ -0,0 +1 @@
+DIST shellish-0.1.4.tar.gz 7268 SHA256 56b97529b71d2a0932925f3808d3d0446f288eddebbdfa8d9f9e5770448bbcd1 SHA512 4507ab92ca2db6a0e79d799ba303b3cb64fa887ec4581f0e1d191340fa7116db2c4bae069d6692c51d3d754ea0672b2d5c12b582d769b81b5b0e25c8c97c8a62 WHIRLPOOL 40ba5e5c78c2769bf09fa2c11d28dcc04e4b9919db408879344218638496cb8c90b9a354d98ef865e34833060fbf254449e8ea467449942edb0634ab15f23066
diff --git a/dev-haskell/shellish/metadata.xml b/dev-haskell/shellish/metadata.xml
new file mode 100644
index 000000000000..e8f79caf3894
--- /dev/null
+++ b/dev-haskell/shellish/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The shellisg package provides a single module for convenient
+ \&quot;systems\&quot; programming in Haskell, similar in spirit to POSIX
+ shells or PERL.
+
+ * Elegance and safety is sacrificed for conciseness and
+ swiss-army-knife-ness.
+
+ * The interface exported by Shellish is thread-safe.
+
+ Overall, the module should help you to get a job done quickly,
+ without getting too dirty.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/shellish/shellish-0.1.4.ebuild b/dev-haskell/shellish/shellish-0.1.4.ebuild
new file mode 100644
index 000000000000..86f421a07c2b
--- /dev/null
+++ b/dev-haskell/shellish/shellish-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="shell-/perl- like (systems) programming in Haskell"
+HOMEPAGE="http://repos.mornfall.net/shellish"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mtl[profile?]
+ dev-haskell/strict[profile?]
+ dev-haskell/unix-compat[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"