summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-29 21:01:31 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-29 21:01:31 +0200
commitade349ebd75d5fdd2641ab49ffb70a3bd6a99c49 (patch)
tree644223f2f806ba9237812c367144dd635ff7ecfb /dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild
parentdev-haskell/skylighting: add missing libpcre dependency (diff)
downloadgentoo-ade349ebd75d5fdd2641ab49ffb70a3bd6a99c49.tar.gz
gentoo-ade349ebd75d5fdd2641ab49ffb70a3bd6a99c49.tar.bz2
gentoo-ade349ebd75d5fdd2641ab49ffb70a3bd6a99c49.zip
dev-haskell/skylighting-core: add missing libpcre dependency
Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild')
-rw-r--r--dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild b/dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild
new file mode 100644
index 000000000000..72fb1c369e7f
--- /dev/null
+++ b/dev-haskell/skylighting-core/skylighting-core-0.10.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +system-pcre
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
+ >=dev-haskell/ansi-terminal-0.7:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/colour-2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-conduit-1.9.1.0:=[profile?] <dev-haskell/xml-conduit-1.10:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ dev-libs/libpcre:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/diff
+ dev-haskell/pretty-show
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ --flag=system-pcre
+}