summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-18 11:08:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-18 11:28:27 +0000
commit244f2233cdbc6197709c0d174c45abd0fb52ae5c (patch)
treefff611fa531631f348c97a812d9e371c57a8859a /dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
parentdev-haskell/weigh: new package, a depend of pandoc-1.19 (diff)
downloadgentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.tar.gz
gentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.tar.bz2
gentoo-244f2233cdbc6197709c0d174c45abd0fb52ae5c.zip
dev-haskell/skylighting: new package, a depend of pandoc-1.19
syntax highlighting library Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/skylighting/skylighting-0.1.1.5.ebuild')
-rw-r--r--dev-haskell/skylighting/skylighting-0.1.1.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
new file mode 100644
index 000000000000..cfc65da0be6e
--- /dev/null
+++ b/dev-haskell/skylighting/skylighting-0.1.1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -bootstrap
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="syntax highlighting library"
+HOMEPAGE="https://github.com/jgm/skylighting"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/hxt:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/regex-pcre-builtin:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ executable? ( dev-haskell/pretty-show:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/random
+ dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ !executable? ( dev-haskell/pretty-show ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bootstrap \
+ $(cabal_flag executable executable)
+}