summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:15:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commitbe1283961b8ac73cba201594a4c5324b776b1089 (patch)
tree9200f8cdda3ab01dc749f8af949754717870b75e /dev-haskell/tagsoup/tagsoup-0.13.8.ebuild
parentdev-haskell/tagged: bump up to 0.8.2 (diff)
downloadgentoo-be1283961b8ac73cba201594a4c5324b776b1089.tar.gz
gentoo-be1283961b8ac73cba201594a4c5324b776b1089.tar.bz2
gentoo-be1283961b8ac73cba201594a4c5324b776b1089.zip
dev-haskell/tagsoup: bump up to 0.13.8
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/tagsoup/tagsoup-0.13.8.ebuild')
-rw-r--r--dev-haskell/tagsoup/tagsoup-0.13.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/tagsoup/tagsoup-0.13.8.ebuild b/dev-haskell/tagsoup/tagsoup-0.13.8.ebuild
new file mode 100644
index 000000000000..b8acec2e0da6
--- /dev/null
+++ b/dev-haskell/tagsoup/tagsoup-0.13.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing and extracting information from (possibly malformed) HTML/XML documents"
+HOMEPAGE="https://github.com/ndmitchell/tagsoup#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="download testprog"
+
+RDEPEND="dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ download? ( dev-haskell/network:=[profile?] )
+ testprog? ( >=dev-haskell/quickcheck-2.4:2=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag download download) \
+ $(cabal_flag testprog testprog)
+}