summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:02 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:12 +0100
commit26aeb2c0a6ead38a173d91df068e79504a9b5c0f (patch)
treed0e21bb8e754b654d84aa71da5eb12ce41f02058 /dev-haskell/tasty/tasty-1.4.2.3.ebuild
parentdev-haskell/tasty-smallcheck: add 0.8.2 (diff)
downloadgentoo-26aeb2c0a6ead38a173d91df068e79504a9b5c0f.tar.gz
gentoo-26aeb2c0a6ead38a173d91df068e79504a9b5c0f.tar.bz2
gentoo-26aeb2c0a6ead38a173d91df068e79504a9b5c0f.zip
dev-haskell/tasty: Add USE=clock
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tasty/tasty-1.4.2.3.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-1.4.2.3.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-haskell/tasty/tasty-1.4.2.3.ebuild b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
index fda420b3c6c9..b53097c063f3 100644
--- a/dev-haskell/tasty/tasty-1.4.2.3.ebuild
+++ b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
@@ -3,28 +3,31 @@
EAPI=8
-# ebuild generated by hackport 0.7.1.1.9999
-#hackport: flags: +clock,+unix
+# ebuild generated by hackport 0.7.3.0
+#hackport: flags: +unix
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Modern and extensible testing framework"
HOMEPAGE="https://github.com/UnkindPartition/tasty"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+clock"
-RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
- >=dev-haskell/clock-0.4.4.0:=[profile?]
+RDEPEND="
+ >=dev-haskell/ansi-terminal-0.9:=[profile?]
>=dev-haskell/optparse-applicative-0.14:=[profile?]
>=dev-haskell/stm-2.3:=[profile?]
>=dev-haskell/tagged-0.5:=[profile?]
>=dev-haskell/unbounded-delays-0.1:=[profile?]
dev-haskell/wcwidth:=[profile?]
>=dev-lang/ghc-8.4.3:=
+ clock? (
+ >=dev-haskell/clock-0.4.4.0:=[profile?]
+ )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
@@ -32,6 +35,6 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- --flag=clock \
+ $(cabal_flag clock clock) \
--flag=unix
}