summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 21:05:47 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:46 +0000
commitabef21421fec599183c6fee935328abf38c0c19f (patch)
tree3cdb45a1aa35e6f7e37043839b6ef40998f3ce35 /dev-haskell/tasty/tasty-1.4.2.3.ebuild
parentdev-haskell/tagsoup: keyword 0.14.8 for ~ppc64 (diff)
downloadgentoo-abef21421fec599183c6fee935328abf38c0c19f.tar.gz
gentoo-abef21421fec599183c6fee935328abf38c0c19f.tar.bz2
gentoo-abef21421fec599183c6fee935328abf38c0c19f.zip
dev-haskell/tasty: add 1.4.2.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tasty/tasty-1.4.2.3.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-1.4.2.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-1.4.2.3.ebuild b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
new file mode 100644
index 000000000000..4f69152fb684
--- /dev/null
+++ b/dev-haskell/tasty/tasty-1.4.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +clock,+unix
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="https://github.com/UnkindPartition/tasty"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9:=[profile?]
+ >=dev-haskell/clock-0.4.4.0:=[profile?]
+ >=dev-haskell/optparse-applicative-0.14:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?]
+ dev-haskell/wcwidth:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=clock \
+ --flag=unix
+}