summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-18 15:28:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-18 15:28:02 +0100
commit981906dbf10e2ae94151b7e3901cde18bd53f45d (patch)
tree062ea8f9d5cad1849d8331140a9a85d1b9beedfc /dev-haskell/text/text-1.2.4.1.ebuild
parentdev-haskell/xhtml: mark bundled with ghc-8.10.5 (diff)
downloadgentoo-981906dbf10e2ae94151b7e3901cde18bd53f45d.tar.gz
gentoo-981906dbf10e2ae94151b7e3901cde18bd53f45d.tar.bz2
gentoo-981906dbf10e2ae94151b7e3901cde18bd53f45d.zip
dev-haskell/text: bump up to 1.2.4.1
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/802750 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/text/text-1.2.4.1.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.4.1.ebuild b/dev-haskell/text/text-1.2.4.1.ebuild
new file mode 100644
index 000000000000..599f550ee58b
--- /dev/null
+++ b/dev-haskell/text/text-1.2.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bytestring-builder,-developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # broken test-suite
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/haskell/text"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10.4
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+# break cyclic dependencies, test suite requires porting to >=QC-2.11
+RESTRICT=test
+RDEPEND=">=dev-lang/ghc-8.8:="
+
+DEPEND="${RDEPEND}
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.3 PM:8.10.4 PM:8.10.5 PM:9.0.1 PM:9999"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ --flag=-developer
+}