summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-14 09:12:17 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 22:32:50 +0000
commit38c3b6355ab9a47a4de16d12dcc7444e72fbb056 (patch)
treee2435fd78a0c8d68558ddf3464f008e98e35c158 /dev-haskell/text/text-1.2.4.1_rc1.ebuild
parentdev-lang/ghc: 8.10: restore keywords (diff)
downloadgentoo-38c3b6355ab9a47a4de16d12dcc7444e72fbb056.tar.gz
gentoo-38c3b6355ab9a47a4de16d12dcc7444e72fbb056.tar.bz2
gentoo-38c3b6355ab9a47a4de16d12dcc7444e72fbb056.zip
dev-haskell/text: bump up to 1.2.4.1_rc1
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/text/text-1.2.4.1_rc1.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.4.1_rc1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.4.1_rc1.ebuild b/dev-haskell/text/text-1.2.4.1_rc1.ebuild
new file mode 100644
index 000000000000..6da0fe1d6e7e
--- /dev/null
+++ b/dev-haskell/text/text-1.2.4.1_rc1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -bytestring-builder,-developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # broken test-suite
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+MY_PV="$(ver_rs 4 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/haskell/text"
+SRC_URI="https://github.com/haskell/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10.3
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+# break cyclic dependencies, test suite requires porting to >=QC-2.11
+RESTRICT=test
+RDEPEND=">=dev-lang/ghc-8.10.3:="
+
+DEPEND="${RDEPEND}
+"
+
+S="${WORKDIR}/${MY_P}"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.3 PM:8.10.4 PM:9999"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ --flag=-developer
+}