summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-21 17:45:31 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:51 +0000
commit77d68ec21b65fc08ea732648ffcecd60001517bb (patch)
tree221dbaeb36ee1ce8be0e0dfe935bd8760954266e /dev-haskell/text/text-1.2.5.0.ebuild
parentdev-haskell/text-icu: add 0.7.1.0 (diff)
downloadgentoo-77d68ec21b65fc08ea732648ffcecd60001517bb.tar.gz
gentoo-77d68ec21b65fc08ea732648ffcecd60001517bb.tar.bz2
gentoo-77d68ec21b65fc08ea732648ffcecd60001517bb.zip
dev-haskell/text: add 1.2.5.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/text/text-1.2.5.0.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.5.0.ebuild b/dev-haskell/text/text-1.2.5.0.ebuild
new file mode 100644
index 000000000000..95b29c908fde
--- /dev/null
+++ b/dev-haskell/text/text-1.2.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -bytestring-builder,-developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # circular deps in test-suite
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/haskell/text"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+#keep in sync with ghc-9.0.2
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+# break cyclic dependencies:
+RESTRICT=test
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ --flag=-developer
+}
+
+CABAL_CORE_LIB_GHC_PV="PM:9.0.2 PM:9999"