summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/tf-random
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/tf-random')
-rw-r--r--dev-haskell/tf-random/Manifest1
-rw-r--r--dev-haskell/tf-random/metadata.xml22
-rw-r--r--dev-haskell/tf-random/tf-random-0.5.ebuild27
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/tf-random/Manifest b/dev-haskell/tf-random/Manifest
new file mode 100644
index 000000000000..885098527f4d
--- /dev/null
+++ b/dev-haskell/tf-random/Manifest
@@ -0,0 +1 @@
+DIST tf-random-0.5.tar.gz 18483 SHA256 2e30cec027b313c9e1794d326635d8fc5f79b6bf6e7580ab4b00186dadc88510 SHA512 a766909571b4b37daaaaa9fa1aa9739bd2db8c32c0f64452fd7c3717f4578090e5227b763772858c6c311c5f366dd461421ffc3beb295455902fea1fb133deb7 WHIRLPOOL 593a67cf1b8dfece25fab4027c44ec2cacd7f4ae072fa185ac60188963d586a1873e2fc665c9ce4cbe0625ee02f304ef238352f9010195bb5f7b8f3c12ac310f
diff --git a/dev-haskell/tf-random/metadata.xml b/dev-haskell/tf-random/metadata.xml
new file mode 100644
index 000000000000..73f4792cf592
--- /dev/null
+++ b/dev-haskell/tf-random/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This package contains an implementation of a high-quality splittable pseudorandom number generator. The generator is based on a cryptographic hash function built on top of the ThreeFish block cipher. See the paper /Splittable Pseudorandom Number Generators Using Cryptographic Hashing/ by Claessen, PaBka for details and the rationale of the design.
+
+ The package provides the following:
+
+ * A splittable PRNG that implements the standard &#39;System.Random.RandomGen&#39; class.
+
+ * The generator also implements an alternative version of the &#39;System.Random.TF.Gen.RandomGen&#39; class (exported from &quot;System.Random.TF.Gen&quot;), which requires the generator to return pseudorandom integers from the full 32-bit range, and contains an n-way split function.
+
+ * An alternative version of the @Random@ class is provided, which is linked to the new @RandomGen@ class, together with @Random@ instances for some integral types.
+
+ * Two functions for initialising the generator with a non-deterministic seed: one using the system time, and one using the @\/dev\/urandom@ UNIX special file.
+
+ The package uses an adapted version of the reference C implementation of ThreeFish from the reference package of the Skein hash function (&lt;https://www.schneier.com/skein.html&gt;), originally written by Doug Whiting.
+
+ Please note that even though the generator provides very high-quality pseudorandom numbers, it has not been designed with cryptographic applications in mind.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/tf-random/tf-random-0.5.ebuild b/dev-haskell/tf-random/tf-random-0.5.ebuild
new file mode 100644
index 000000000000..b80429015e53
--- /dev/null
+++ b/dev-haskell/tf-random/tf-random-0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile" # non-ASCII in .cabal: haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="High-quality splittable pseudorandom number generator"
+HOMEPAGE="http://hackage.haskell.org/package/tf-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/primitive-0.3:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"