summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:18 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:15 +0100
commit72e5d06987c2bf9b1fa093e05c376a63c23b4a06 (patch)
treed122b54a906ca5e78a3315c6a5aee04f880c230f /dev-haskell/time-compat
parentdev-haskell/these: add 1.2 (diff)
downloadgentoo-72e5d06987c2bf9b1fa093e05c376a63c23b4a06.tar.gz
gentoo-72e5d06987c2bf9b1fa093e05c376a63c23b4a06.tar.bz2
gentoo-72e5d06987c2bf9b1fa093e05c376a63c23b4a06.zip
dev-haskell/time-compat: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/time-compat')
-rw-r--r--dev-haskell/time-compat/Manifest2
-rw-r--r--dev-haskell/time-compat/metadata.xml4
-rw-r--r--dev-haskell/time-compat/time-compat-1.9.6.1-r1.ebuild41
-rw-r--r--dev-haskell/time-compat/time-compat-1.9.6.1.ebuild49
4 files changed, 46 insertions, 50 deletions
diff --git a/dev-haskell/time-compat/Manifest b/dev-haskell/time-compat/Manifest
index e4c200eb3949..d51aa4809fb5 100644
--- a/dev-haskell/time-compat/Manifest
+++ b/dev-haskell/time-compat/Manifest
@@ -1,2 +1,2 @@
-DIST time-compat-1.9.6.1.cabal 5033 BLAKE2B bd54030fd2ea681d4b50eebbf05db7a8080c0023aaa845d285e4b9c15c86d9b578446c690d5053c00da27a28ee77be5ee4a728a9d120f98271f57128b4fada2a SHA512 9643dcfd5e6397b00b16547fc5eff687363d5921b44293d2e80e665392ee853315da84cfb3aa91ee8f225bee1966b281af80a5a549bdfa10b42444f27b097890
+DIST time-compat-1.9.6.1-rev5.cabal 5062 BLAKE2B be9fb65c60bc62b7b92ec552ef691121084b67d05f329f32a6cd9af8f57663e8be7b31510e5a5080db38d711a06a91a9de705fbd8e3ad6697b6451f95ddedb7b SHA512 6ab42c2ad2d53b4bb9e713886508691cfc0f13535524e2cf0311110b8bf991474b6efd030ec74dfda056d154cdbb409cc7caea087645e91d50a96e2a5c07a979
DIST time-compat-1.9.6.1.tar.gz 59964 BLAKE2B 0a19a9692100d47f14643613539061104fead78056d37ff3aededf3d15ef00e23aa6875b77b56a92138818511b7681197ff55fb8adb6a0d6075c7e02bf0fe397 SHA512 ca0b19aa5e7948fd7d9fbd8ff5e1b0f93a2d8d410d515e7078b40370e7d9fc363c111d53551d57a0320efb0894bcc2210afa8fc04da9f003ded626f53b7e58ea
diff --git a/dev-haskell/time-compat/metadata.xml b/dev-haskell/time-compat/metadata.xml
index 937381521944..9eefe1548660 100644
--- a/dev-haskell/time-compat/metadata.xml
+++ b/dev-haskell/time-compat/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">time-compat</remote-id>
+ <remote-id type="github">haskellari/time-compat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/time-compat/time-compat-1.9.6.1-r1.ebuild b/dev-haskell/time-compat/time-compat-1.9.6.1-r1.ebuild
new file mode 100644
index 000000000000..927540bc987f
--- /dev/null
+++ b/dev-haskell/time-compat/time-compat-1.9.6.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+
+CABAL_HACKAGE_REVISION=5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compatibility package for time"
+HOMEPAGE="https://github.com/haskellari/time-compat"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=( "${FILESDIR}/fix-resolution-test.patch" )
+
+RDEPEND="
+ >=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-0.10:=[profile?]
+ >=dev-haskell/hashable-1.3.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/base-compat-0.10.5 <dev-haskell/base-compat-0.14
+ >=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tagged-0.8.6 <dev-haskell/tagged-0.9
+ >=dev-haskell/tasty-1.2.1 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11
+ || (
+ ( >=dev-haskell/hunit-1.3.1 <dev-haskell/hunit-1.3.2 )
+ ( >=dev-haskell/hunit-1.6.0.0 <dev-haskell/hunit-1.7 )
+ )
+ )
+"
diff --git a/dev-haskell/time-compat/time-compat-1.9.6.1.ebuild b/dev-haskell/time-compat/time-compat-1.9.6.1.ebuild
deleted file mode 100644
index a40b9786b63b..000000000000
--- a/dev-haskell/time-compat/time-compat-1.9.6.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.1.1.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-CABAL_HACKAGE_REVISION="3"
-inherit haskell-cabal
-
-DESCRIPTION="Compatibility package for time"
-HOMEPAGE="https://github.com/haskellari/time-compat"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
- https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-0.9:=[profile?]
- >=dev-haskell/hashable-1.3.2.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
- >=dev-lang/ghc-8.4.3:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- test? ( >=dev-haskell/base-compat-0.10.5 <dev-haskell/base-compat-0.13
- >=dev-haskell/quickcheck-2.13 <dev-haskell/quickcheck-2.15
- >=dev-haskell/tagged-0.8.6 <dev-haskell/tagged-0.9
- >=dev-haskell/tasty-1.2.1 <dev-haskell/tasty-1.5
- >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
- >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11
- || ( ( >=dev-haskell/hunit-1.3.1 <dev-haskell/hunit-1.3.2 )
- ( >=dev-haskell/hunit-1.6.0.0 <dev-haskell/hunit-1.7 ) ) )
-"
-BDEPEND="app-text/dos2unix"
-
-PATCHES=( "${FILESDIR}/fix-resolution-test.patch" )
-
-src_prepare() {
- # pull revised cabal from upstream
- cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
-
- # Convert to unix line endings
- dos2unix "${S}/${PN}.cabal" || die
-
- # Apply patches *after* pulling the revised cabal
- default
-}