summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-19 21:50:15 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-19 22:29:01 +0000
commitd54c126ce6f617c979ae3f71be54f67e81de15f5 (patch)
treee0e2403d160cefceaa9c3688fc7be7c27078437d /dev-haskell/tls/tls-1.3.4.ebuild
parentdev-haskell/x509-validation: bump up to 1.6.3 (diff)
downloadgentoo-d54c126ce6f617c979ae3f71be54f67e81de15f5.tar.gz
gentoo-d54c126ce6f617c979ae3f71be54f67e81de15f5.tar.bz2
gentoo-d54c126ce6f617c979ae3f71be54f67e81de15f5.zip
dev-haskell/tls: bump up to 1.3.4
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/tls/tls-1.3.4.ebuild')
-rw-r--r--dev-haskell/tls/tls-1.3.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/tls/tls-1.3.4.ebuild b/dev-haskell/tls/tls-1.3.4.ebuild
new file mode 100644
index 000000000000..bef0dc79f884
--- /dev/null
+++ b/dev-haskell/tls/tls-1.3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -hans
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="https://github.com/vincenthz/hs-tls"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat +network"
+
+RDEPEND="dev-haskell/asn1-encoding:=[profile?]
+ >=dev-haskell/asn1-types-0.2.0:=[profile?]
+ dev-haskell/async:=[profile?]
+ >=dev-haskell/cereal-0.4:=[profile?]
+ >=dev-haskell/cryptonite-0.7:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/x509-1.6.2:=[profile?] <dev-haskell/x509-1.7.0:=[profile?]
+ >=dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-haskell/x509-validation-1.6.3:=[profile?] <dev-haskell/x509-validation-1.7.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network? ( dev-haskell/network:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hourglass
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat) \
+ --flag=-hans \
+ $(cabal_flag network network)
+}