summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 21:48:32 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commitbdcd91e8f1261c3f3cf31cf2600f1ab32bf750b4 (patch)
tree5c535aa04f43d35278479f4c2744d3424e2840e5 /dev-haskell/uuid/uuid-1.3.12.ebuild
parentmedia-video/ffmpeg: nvenc does not require nonfree binary anymore; required h... (diff)
downloadgentoo-bdcd91e8f1261c3f3cf31cf2600f1ab32bf750b4.tar.gz
gentoo-bdcd91e8f1261c3f3cf31cf2600f1ab32bf750b4.tar.bz2
gentoo-bdcd91e8f1261c3f3cf31cf2600f1ab32bf750b4.zip
dev-haskell/uuid: bump up to 1.3.12
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-haskell/uuid/uuid-1.3.12.ebuild')
-rw-r--r--dev-haskell/uuid/uuid-1.3.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/uuid/uuid-1.3.12.ebuild b/dev-haskell/uuid/uuid-1.3.12.ebuild
new file mode 100644
index 000000000000..790108d447bd
--- /dev/null
+++ b/dev-haskell/uuid/uuid-1.3.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="For creating, comparing, parsing and printing Universally Unique Identifiers"
+HOMEPAGE="https://github.com/aslatter/uuid"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.9:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/memory:=[profile?]
+ >=dev-haskell/network-info-0.2:=[profile?] <dev-haskell/network-info-0.3:=[profile?]
+ >=dev-haskell/random-1.0.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/text-1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.4
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/tasty-0.10 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"