summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-14 10:20:54 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 09:07:11 +0000
commit4d67aba0ae45715b3834fdf0c0dd694fdbaa46b2 (patch)
tree0b8b3c67e883e0231e585afb31c9f719f60b9d4b /dev-haskell/vault/vault-0.3.1.4.ebuild
parentdev-haskell/tar: allow ghc-8.10 (diff)
downloadgentoo-4d67aba0ae45715b3834fdf0c0dd694fdbaa46b2.tar.gz
gentoo-4d67aba0ae45715b3834fdf0c0dd694fdbaa46b2.tar.bz2
gentoo-4d67aba0ae45715b3834fdf0c0dd694fdbaa46b2.zip
dev-haskell/vault: bump up to 0.3.1.4
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/vault/vault-0.3.1.4.ebuild')
-rw-r--r--dev-haskell/vault/vault-0.3.1.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/vault/vault-0.3.1.4.ebuild b/dev-haskell/vault/vault-0.3.1.4.ebuild
new file mode 100644
index 000000000000..48f582ae33e1
--- /dev/null
+++ b/dev-haskell/vault/vault-0.3.1.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: +useghc
+
+CABAL_FEATURES="lib profile haddock hoogle" # disable hscolour: ghc-8.8.1 is buggy: https://github.com/haskell/haddock/issues/1091
+inherit haskell-cabal
+
+DESCRIPTION="a persistent store for values of arbitrary types"
+HOMEPAGE="https://github.com/HeinrichApfelmus/vault"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.5:=[profile?] <dev-haskell/hashable-1.4:=[profile?]
+ >=dev-haskell/semigroups-0.1:=[profile?] <dev-haskell/semigroups-1.0:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=useghc
+}