summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:52 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:24 +0100
commite94f0c548a3bb3a071859aaa501437eeac25fd82 (patch)
treec64282c904dff6183644e0f3bab4cc941403b67e /dev-haskell/vector-th-unbox
parentdev-haskell/vector-binary-instances: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-e94f0c548a3bb3a071859aaa501437eeac25fd82.tar.gz
gentoo-e94f0c548a3bb3a071859aaa501437eeac25fd82.tar.bz2
gentoo-e94f0c548a3bb3a071859aaa501437eeac25fd82.zip
dev-haskell/vector-th-unbox: add 0.2.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/vector-th-unbox')
-rw-r--r--dev-haskell/vector-th-unbox/Manifest2
-rw-r--r--dev-haskell/vector-th-unbox/metadata.xml10
-rw-r--r--dev-haskell/vector-th-unbox/vector-th-unbox-0.2.2.ebuild26
3 files changed, 32 insertions, 6 deletions
diff --git a/dev-haskell/vector-th-unbox/Manifest b/dev-haskell/vector-th-unbox/Manifest
index b44ba5a7bb6f..2a47db129c81 100644
--- a/dev-haskell/vector-th-unbox/Manifest
+++ b/dev-haskell/vector-th-unbox/Manifest
@@ -1 +1,3 @@
DIST vector-th-unbox-0.2.1.7.tar.gz 4771 BLAKE2B 72d25981c2dd42bce7028d94a1805ad9a836cfbdce9dfb8bdbfe2f1aa26f4180ea8fc02b3323eccaa11c53065659ddc25063460b737831cc565ae08cecc914d4 SHA512 fa65c32eace3ad93f0df69830eca0334519bbdbb2bbdc511db6e6abffe48c78870fef131dc34451873775a037634a87f0cd0d06dc1c4bc9404af2a86d7593ae1
+DIST vector-th-unbox-0.2.2-rev4.cabal 1565 BLAKE2B cd49e8c28667981719bb811a0367e47c1a8953be340abc5e9ebb608520e09c292d3e4bffa5059a22d0362778b63d7a77bc78d552f22571ae27c24f726bd095e4 SHA512 c6bf6404e44d0c128a36106916810eb5f21c93cd40593fa3717028c4f36165a3ff33320d853759ad35e3f7665dba57458dc7004d14cce30cd129ef1ee7fc9414
+DIST vector-th-unbox-0.2.2.tar.gz 4864 BLAKE2B 6c7cabc49af5f06332802c41f37ca92a7fc8df48c288cceaee786aaf38b8f19f5576ccac3e86dd04a62431d42c5d1e0bd2269a5b5bf4e6558a2a76810dcba7f1 SHA512 55af4bcced3a39464aca6dca95a8148498a698d9402a583b916aa178d58d3895cc609525416de53c0a39566b892c7b09296fc442db7851a19d071142cce72a46
diff --git a/dev-haskell/vector-th-unbox/metadata.xml b/dev-haskell/vector-th-unbox/metadata.xml
index d3891236a6d7..e088f89cce76 100644
--- a/dev-haskell/vector-th-unbox/metadata.xml
+++ b/dev-haskell/vector-th-unbox/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A Template Haskell deriver for unboxed vectors, given a pair of coercion
- functions to and from some existing type with an Unbox instance.
-
- Refer to "Data.Vector.Unboxed.Deriving" for documentation and examples.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">vector-th-unbox</remote-id>
+ <remote-id type="github">tsurucapital/vector-th-unbox</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/vector-th-unbox/vector-th-unbox-0.2.2.ebuild b/dev-haskell/vector-th-unbox/vector-th-unbox-0.2.2.ebuild
new file mode 100644
index 000000000000..130f998cd233
--- /dev/null
+++ b/dev-haskell/vector-th-unbox/vector-th-unbox-0.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Deriver for Data.Vector.Unboxed using Template Haskell"
+HOMEPAGE="https://github.com/tsurucapital/vector-th-unbox"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/vector-0.7.1:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/data-default )
+"