summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:29:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit41ef99e8085860ba55e7bc9de0002c94489a9c08 (patch)
tree69e0db1632f01860fda24e8042e0bd6bca85b91b /dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
parentdev-haskell/wai: bump up to 3.0.5.0 (diff)
downloadgentoo-41ef99e8085860ba55e7bc9de0002c94489a9c08.tar.gz
gentoo-41ef99e8085860ba55e7bc9de0002c94489a9c08.tar.bz2
gentoo-41ef99e8085860ba55e7bc9de0002c94489a9c08.zip
dev-haskell/wai-app-static: bump up to 3.1.4.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild')
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
new file mode 100644
index 000000000000..69af1432ea97
--- /dev/null
+++ b/dev-haskell/wai-app-static/wai-app-static-3.1.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="WAI application for static serving"
+HOMEPAGE="http://www.yesodweb.com/book/web-application-interface"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="print"
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?]
+ dev-haskell/cryptohash-conduit:=[profile?]
+ >=dev-haskell/file-embed-0.0.3.1:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/mime-types-0.1:=[profile?] <dev-haskell/mime-types-0.2:=[profile?]
+ >=dev-haskell/old-locale-1.0.0.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.7:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/wai-extra-3.0:=[profile?] <dev-haskell/wai-extra-3.1:=[profile?]
+ >=dev-haskell/warp-3.0.11:=[profile?] <dev-haskell/warp-3.3:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/network
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag print print)
+}