summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-19 21:45:04 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-19 22:29:01 +0000
commit67686d2b79e89d923feecd42a168bb724a4ec094 (patch)
tree40d41e88c29c35ec15f8c1443e0de5f2312e367a /dev-haskell/x509/x509-1.6.3.ebuild
parentdev-haskell/cryptonite: new package, a depend of dev-haskell/x509-1.6 (diff)
downloadgentoo-67686d2b79e89d923feecd42a168bb724a4ec094.tar.gz
gentoo-67686d2b79e89d923feecd42a168bb724a4ec094.tar.bz2
gentoo-67686d2b79e89d923feecd42a168bb724a4ec094.zip
dev-haskell/x509: bump up to 1.6.3
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-haskell/x509/x509-1.6.3.ebuild')
-rw-r--r--dev-haskell/x509/x509-1.6.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/x509/x509-1.6.3.ebuild b/dev-haskell/x509/x509-1.6.3.ebuild
new file mode 100644
index 000000000000..19f0172c5f0d
--- /dev/null
+++ b/dev-haskell/x509/x509-1.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="X509 reader and writer"
+HOMEPAGE="https://github.com/vincenthz/hs-certificate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
+ >=dev-haskell/asn1-parse-0.9.3:=[profile?] <dev-haskell/asn1-parse-0.10:=[profile?]
+ >=dev-haskell/asn1-types-0.3.1:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"