summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 20:50:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:55 +0000
commit83cabe71c3e24c741dacf40cf000226da19d8f6a (patch)
treea10f98c72a613de7c2dd42bd557038442f2df69e /dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild
parentdev-haskell/yesod-core: bump up to 1.4.31 (diff)
downloadgentoo-83cabe71c3e24c741dacf40cf000226da19d8f6a.tar.gz
gentoo-83cabe71c3e24c741dacf40cf000226da19d8f6a.tar.bz2
gentoo-83cabe71c3e24c741dacf40cf000226da19d8f6a.zip
dev-haskell/yesod-auth: bump up to 1.4.16
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild')
-rw-r--r--dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild b/dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild
new file mode 100644
index 000000000000..812c741a56eb
--- /dev/null
+++ b/dev-haskell/yesod-auth/yesod-auth-1.4.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication for Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/authenticate-1.3:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/email-validate-1.0:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/http-client:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/mime-mail-0.3:=[profile?]
+ >=dev-haskell/nonce-1.0.2:=[profile?] <dev-haskell/nonce-1.1:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.7:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.7:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.4:=[profile?]
+ >=dev-haskell/yesod-core-1.4.31:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+ >=dev-haskell/yesod-persistent-1.4:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}