summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 20:51:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:56 +0000
commitd01ca6921fbf0a5493a1c8e4ccb3beecfd85aa2f (patch)
tree647e8e6bdec6230c6ce4f8d46e87f28d6f2eb1b6 /dev-haskell/yesod/yesod-1.4.4.ebuild
parentdev-haskell/conduit-extra: bump up to 1.1.15 (diff)
downloadgentoo-d01ca6921fbf0a5493a1c8e4ccb3beecfd85aa2f.tar.gz
gentoo-d01ca6921fbf0a5493a1c8e4ccb3beecfd85aa2f.tar.bz2
gentoo-d01ca6921fbf0a5493a1c8e4ccb3beecfd85aa2f.zip
dev-haskell/yesod: bump up to 1.4.4
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/yesod/yesod-1.4.4.ebuild')
-rw-r--r--dev-haskell/yesod/yesod-1.4.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/yesod/yesod-1.4.4.ebuild b/dev-haskell/yesod/yesod-1.4.4.ebuild
new file mode 100644
index 000000000000..c9d8dfeaff4a
--- /dev/null
+++ b/dev-haskell/yesod/yesod-1.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Creation of type-safe, RESTful web applications"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ >=dev-haskell/conduit-extra-1.1.14:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/fast-logger:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ dev-haskell/monad-logger:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/semigroups:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/warp-1.3:=[profile?]
+ >=dev-haskell/yaml-0.8.17:=[profile?]
+ >=dev-haskell/yesod-core-1.4:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+ >=dev-haskell/yesod-persistent-1.4:=[profile?] <dev-haskell/yesod-persistent-1.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"