summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-06 11:00:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-06 12:02:40 +0000
commitf8369371428781a9d85b012e05f28ce4268f4e3f (patch)
treea6a13efa3406c8483110430274ce41a78754aa10 /dev-haskell/zlib/zlib-0.6.1.2.ebuild
parentdev-haskell/zlib-enum: allow ghc-8 (diff)
downloadgentoo-f8369371428781a9d85b012e05f28ce4268f4e3f.tar.gz
gentoo-f8369371428781a9d85b012e05f28ce4268f4e3f.tar.bz2
gentoo-f8369371428781a9d85b012e05f28ce4268f4e3f.zip
dev-haskell/zlib: bump up to 0.6.1.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-haskell/zlib/zlib-0.6.1.2.ebuild')
-rw-r--r--dev-haskell/zlib/zlib-0.6.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/zlib/zlib-0.6.1.2.ebuild b/dev-haskell/zlib/zlib-0.6.1.2.ebuild
new file mode 100644
index 000000000000..18307802c95c
--- /dev/null
+++ b/dev-haskell/zlib/zlib-0.6.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Compression and decompression in the gzip and zlib formats"
+HOMEPAGE="http://hackage.haskell.org/package/zlib"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-macos"
+IUSE="non-blocking-ffi"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ >=dev-haskell/tasty-0.8 <dev-haskell/tasty-0.12
+ >=dev-haskell/tasty-hunit-0.8 <dev-haskell/tasty-hunit-0.10
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag non-blocking-ffi non-blocking-ffi)
+}