summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-17 08:02:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-17 08:03:15 +0100
commit0eedc83e5d90b37e4680f1f96e531aa82e69d591 (patch)
tree3a2972bef7e08490a7d5b5d2bb5d9bb71b4bca28 /dev-haskell
parentsys-devel/llvm-common: Remove 11.0.1 (diff)
downloadgentoo-0eedc83e5d90b37e4680f1f96e531aa82e69d591.tar.gz
gentoo-0eedc83e5d90b37e4680f1f96e531aa82e69d591.tar.bz2
gentoo-0eedc83e5d90b37e4680f1f96e531aa82e69d591.zip
dev-haskell/cpu: drop USE=executable
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/790233 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cpu/cpu-0.1.2.ebuild12
-rw-r--r--dev-haskell/cpu/metadata.xml6
2 files changed, 6 insertions, 12 deletions
diff --git a/dev-haskell/cpu/cpu-0.1.2.ebuild b/dev-haskell/cpu/cpu-0.1.2.ebuild
index 83f422c0e3b6..50373b2b7aeb 100644
--- a/dev-haskell/cpu/cpu-0.1.2.ebuild
+++ b/dev-haskell/cpu/cpu-0.1.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# ebuild generated by hackport 0.6.6.9999
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -executable
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
@@ -15,15 +16,14 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="executable"
-RDEPEND=">=dev-lang/ghc-7.4.1:=
+RDEPEND=">=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
+ >=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag executable executable)
+ --flag=-executable
}
diff --git a/dev-haskell/cpu/metadata.xml b/dev-haskell/cpu/metadata.xml
index aa5b10119e39..1c2f3eaf5db7 100644
--- a/dev-haskell/cpu/metadata.xml
+++ b/dev-haskell/cpu/metadata.xml
@@ -5,12 +5,6 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <use>
- <flag name="executable">build 'cpuid' tool</flag>
- </use>
- <longdescription>
- Lowlevel cpu routines to get basic properties of the cpu platform, like endianness and architecture.
- </longdescription>
<upstream>
<remote-id type="github">vincenthz/hs-cpu</remote-id>
</upstream>