summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:38:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-04-21 08:40:24 +0100
commit18ae2fb979d32d516c7d76bc66b297b4c0c5d187 (patch)
tree55ee62bf2994106e77f85f761ba7f2410698b29b /dev-haskell
parentdev-haskell/ghc-lib-parser-ex: new package, a depend of hlint-3 (diff)
downloadgentoo-18ae2fb979d32d516c7d76bc66b297b4c0c5d187.tar.gz
gentoo-18ae2fb979d32d516c7d76bc66b297b4c0c5d187.tar.bz2
gentoo-18ae2fb979d32d516c7d76bc66b297b4c0c5d187.zip
dev-haskell/hlint: bump up to 3.2.7
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hlint/Manifest1
-rw-r--r--dev-haskell/hlint/hlint-3.2.7.ebuild59
-rw-r--r--dev-haskell/hlint/metadata.xml7
3 files changed, 63 insertions, 4 deletions
diff --git a/dev-haskell/hlint/Manifest b/dev-haskell/hlint/Manifest
index 9874fd2d96fb..17807ab457af 100644
--- a/dev-haskell/hlint/Manifest
+++ b/dev-haskell/hlint/Manifest
@@ -1 +1,2 @@
DIST hlint-2.1.17.tar.gz 119243 BLAKE2B 09d70dffdaec25e8f574fb4dd1f6012828cc8032e38b9275a676b836bff0a86e331ac4e7780618001931622e985ad4a9bd799267b06dee059f3f1b28b33bdf16 SHA512 b0a78fa970bcf2b74d969e1825dee1c7382fb5cebc47f3c752f3b3d5915905943dff21e36f8c0158e3bd10696c4785a2c86a2e1abfcf72b610ab2b564f3be5f3
+DIST hlint-3.2.7.tar.gz 159088 BLAKE2B 5fde93d35093aff4c56dd2b39f2f2318872b6d85cfa1d8ee21aaa7c970ecbd013eb5cac3b9d8742139fe3fa1e5c251364ea479facbc54338adcec5717e31dfaa SHA512 5db66f671d18279d5f4da8b158c9947e95804eff97b2efe1b53a2e3f0f5e23d7560c8085a253031e57d20bb77da0c266f2143b3b03899bfaa1a311d3ace2985b
diff --git a/dev-haskell/hlint/hlint-3.2.7.ebuild b/dev-haskell/hlint/hlint-3.2.7.ebuild
new file mode 100644
index 000000000000..a66d70328900
--- /dev/null
+++ b/dev-haskell/hlint/hlint-3.2.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -ghc-lib
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Source code suggestions"
+HOMEPAGE="https://github.com/ndmitchell/hlint#readme"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gpl hsyaml +threaded test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-haskell/aeson-1.1.2.0:=[profile?]
+ >=dev-haskell/ansi-terminal-0.8.1:=[profile?]
+ >=dev-haskell/cmdargs-0.10:=[profile?]
+ >=dev-haskell/cpphs-1.20.1:=[profile?]
+ >=dev-haskell/data-default-0.3:=[profile?]
+ >=dev-haskell/extra-1.7.3:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/filepattern-0.1.1:=[profile?]
+ >=dev-haskell/ghc-lib-parser-8.10:=[profile?] <dev-haskell/ghc-lib-parser-8.11:=[profile?]
+ >=dev-haskell/ghc-lib-parser-ex-8.10.0.17:=[profile?] <dev-haskell/ghc-lib-parser-ex-8.10.1:=[profile?]
+ >=dev-haskell/refact-0.3:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/uniplate-1.5:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ gpl? ( >=dev-haskell/hscolour-1.21:=[profile?] )
+ hsyaml? ( >=dev-haskell/hsyaml-0.2:=[profile?]
+ >=dev-haskell/hsyaml-aeson-0.2:=[profile?] )
+ !hsyaml? ( >=dev-haskell/yaml-0.5.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-ghc-lib \
+ $(cabal_flag gpl gpl) \
+ $(cabal_flag hsyaml hsyaml) \
+ $(cabal_flag threaded threaded)
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/dist/build${LD_LIBRARY_PATH+:}:${LD_LIBRARY_PATH}"
+ "${S}"/dist/build/hlint/hlint --datadir="${S}"/data --test || die
+}
diff --git a/dev-haskell/hlint/metadata.xml b/dev-haskell/hlint/metadata.xml
index bea62cfa5834..a33e9d0bc4b3 100644
--- a/dev-haskell/hlint/metadata.xml
+++ b/dev-haskell/hlint/metadata.xml
@@ -6,9 +6,8 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="gpl">Use GPL libraries, specifically hscolour.</flag>
+ <flag name="gpl">Use GPL libraries, specifically hscolour</flag>
+ <flag name="hsyaml">Use HsYAML instead of yaml</flag>
+ <flag name="threaded">Build with support for multithreaded execution</flag>
</use>
- <upstream>
- <remote-id type="github">ndmitchell/hlint</remote-id>
- </upstream>
</pkgmetadata>