summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-14 08:14:46 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-14 08:16:41 +0100
commit32e41084d496808c88e73e2f866726f1b150671b (patch)
tree691a6ad034e0e3bae25d7c175b04b721e28801c6 /dev-haskell
parentprofiles: mask ruby26 per profile (diff)
downloadgentoo-32e41084d496808c88e73e2f866726f1b150671b.tar.gz
gentoo-32e41084d496808c88e73e2f866726f1b150671b.tar.bz2
gentoo-32e41084d496808c88e73e2f866726f1b150671b.zip
dev-haskell/hashed-storage: drop masked package
Closes: https://bugs.gentoo.org/735998 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hashed-storage/Manifest1
-rw-r--r--dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch16
-rw-r--r--dev-haskell/hashed-storage/files/hashed-storage-0.5.11-ghc-7.10.patch8
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild56
-rw-r--r--dev-haskell/hashed-storage/metadata.xml22
5 files changed, 0 insertions, 103 deletions
diff --git a/dev-haskell/hashed-storage/Manifest b/dev-haskell/hashed-storage/Manifest
deleted file mode 100644
index 8f5bbc43583d..000000000000
--- a/dev-haskell/hashed-storage/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST hashed-storage-0.5.11.tar.gz 57315 BLAKE2B a97a706446117dc049810b054cad25e62b75be905a0379ef935deb2c1fee6c2de0dece3bf74917bf7bb781f6a90a989ed8b164b3d871768c6c4e9182ffdbf488 SHA512 11bfc05ecb2de5adc5a46116d15d969207a310583e7183e2a21ef767a23eabc55622c84ef351ace81a29800a544358c604b4a255800a713af01266331bf321ba
diff --git a/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch b/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch
deleted file mode 100644
index 1a001e73f537..000000000000
--- a/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Storage/Hashed/Test.hs b/Storage/Hashed/Test.hs
-index d3cab6f..7f8291e 100644
---- a/Storage/Hashed/Test.hs
-+++ b/Storage/Hashed/Test.hs
-@@ -1,2 +1,2 @@
--{-# LANGUAGE ScopedTypeVariables, FlexibleInstances #-}
-+{-# LANGUAGE ScopedTypeVariables, FlexibleInstances, CPP #-}
- module Storage.Hashed.Test( tests ) where
-@@ -464,2 +464,3 @@ posix = [ testCase "getFileStatus" $ check_stat Posix.getFileStatus
-
-+#if ! MIN_VERSION_QuickCheck(2,8,2)
- instance (Arbitrary a, Ord a) => Arbitrary (S.Set a)
-@@ -469,2 +470,3 @@ instance (Arbitrary k, Arbitrary v, Ord k) => Arbitrary (M.Map k v)
- where arbitrary = M.fromList `fmap` arbitrary
-+#endif
-
diff --git a/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-ghc-7.10.patch b/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-ghc-7.10.patch
deleted file mode 100644
index f071cab314fb..000000000000
--- a/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-ghc-7.10.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff --git a/Storage/Hashed/Monad.hs b/Storage/Hashed/Monad.hs
-index 67287b4..bf8ad38 100644
---- a/Storage/Hashed/Monad.hs
-+++ b/Storage/Hashed/Monad.hs
-@@ -1,2 +1,3 @@
- {-# LANGUAGE ScopedTypeVariables, BangPatterns, TypeSynonymInstances, UndecidableInstances, FlexibleInstances #-}
-+{-# LANGUAGE FlexibleContexts #-}
-
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild
deleted file mode 100644
index c4dd82139904..000000000000
--- a/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Hashed file storage support code"
-HOMEPAGE="https://hackage.haskell.org/package/hashed-storage"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x86-macos"
-IUSE="diff hpc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-haskell/binary:=[profile?]
- dev-haskell/dataenc:=[profile?]
- dev-haskell/extensible-exceptions:=[profile?]
- >=dev-haskell/mmap-0.5:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/zlib:=[profile?]
- >=dev-lang/ghc-7.4.1:=
- diff? ( dev-haskell/lcs:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6
- test? ( dev-haskell/hunit:=[profile?]
- >=dev-haskell/quickcheck-2.3:2=[profile?]
- dev-haskell/test-framework:=[profile?]
- dev-haskell/test-framework-hunit:=[profile?]
- dev-haskell/test-framework-quickcheck2:=[profile?]
- dev-haskell/zip-archive:=[profile?] )
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
- epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag diff diff) \
- $(cabal_flag hpc hpc) \
- $(cabal_flag test test)
-}
-
-src_install() {
- haskell-cabal_src_install
-
- use test && rm "${ED}/usr/bin/hashed-storage-test"
-}
diff --git a/dev-haskell/hashed-storage/metadata.xml b/dev-haskell/hashed-storage/metadata.xml
deleted file mode 100644
index af6dbebb7a30..000000000000
--- a/dev-haskell/hashed-storage/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Support code for reading and manipulating hashed file storage
- (where each file and directory is associated with a
- cryptographic hash, for corruption-resistant storage and fast
- comparisons).
-
- The supported storage formats include darcs hashed pristine, a
- plain filesystem tree and an indexed plain tree (where the index
- maintains hashes of the plain files and directories).
- </longdescription>
- <use>
- <flag name="diff">Provide the Storage.Hashed.Diff module.</flag>
- <flag name="hpc">Compile with the profiling ghc flag -fhpc.</flag>
- </use>
-</pkgmetadata>