summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 22:54:14 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:48 +0000
commit36d10ec0e5e403218fbca54452d2441839a267d8 (patch)
tree6d70d8146b9aec4c7c81430706d2fd3ca61f8086 /dev-haskell
parentdev-haskell/aeson: add 1.5.6.0 (diff)
downloadgentoo-36d10ec0e5e403218fbca54452d2441839a267d8.tar.gz
gentoo-36d10ec0e5e403218fbca54452d2441839a267d8.tar.bz2
gentoo-36d10ec0e5e403218fbca54452d2441839a267d8.zip
dev-haskell/aeson-pretty: add 0.8.9
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/aeson-pretty/Manifest2
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.8.9.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/aeson-pretty/Manifest b/dev-haskell/aeson-pretty/Manifest
index 6463e1c0e00f..73bd1fcd6974 100644
--- a/dev-haskell/aeson-pretty/Manifest
+++ b/dev-haskell/aeson-pretty/Manifest
@@ -1 +1,3 @@
DIST aeson-pretty-0.8.8.tar.gz 5600 BLAKE2B cac5605b17405868ea373806021e9ba2b3bd3bcb864e97067d4086289a53c2118922e318fb966172a0c0cf0df900e577698afdcea1291464151fc0a01f359dde SHA512 5867343c5d51d632bb299fcbc00cdb29b0feb1931f0ff9c3cf89c5752f1a103c68c9e6fa65e8538ac19212853c39f6d1d6e0c2d9f0bf49fe001c1bfd792db779
+DIST aeson-pretty-0.8.9.cabal 2549 BLAKE2B 8039fb1ab628e04e0661331860ee2340c1dde9ed971619bdceb8b31500037fa94977034e07a9b8722b7bba818bda0b9b23cc608b71084121c276bce9a7e805da SHA512 b602bd81625dfd00906dd61613c2f4446f88c3afb82a0dec960de62802f5db17d2d77895f22108660f500831d9b0f24f5709b45b0f17f98630442842954dd5b7
+DIST aeson-pretty-0.8.9.tar.gz 5802 BLAKE2B 85d13676bb6f569a9df0f88a0882f493a6a2e55a74e702fa14f1d419b337f2a9f9d531de3dbd5283c80237e6fac11babf5aaba8f29aaf272ce6fc062412f1878 SHA512 00c99799cbe9e268109116f909ea0d9ef2708e578ec363ba5455b43d76d1f89bc9820dcbd3a63a1fb300460d97a71105f028f4ad9853b56ce16a097826b1d3d5
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.9.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.9.ebuild
new file mode 100644
index 000000000000..fe8d70eb0033
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.8.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+HACKAGE_REV="1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="lib-only"
+
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.14.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/aeson-1.0:=[profile?] <dev-haskell/aeson-2.1:=[profile?]
+ !lib-only? ( >=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lib-only lib-only)
+}
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}