summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-18 08:31:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-18 08:36:38 +0000
commit4e5a338036457d556976a99be3f77aa4209bab40 (patch)
tree37213bb7dce5618e60fe7cabf079b7de34bc3aa0 /dev-haskell
parentdev-haskell/doctemplates: bump up to 0.9 (diff)
downloadgentoo-4e5a338036457d556976a99be3f77aa4209bab40.tar.gz
gentoo-4e5a338036457d556976a99be3f77aa4209bab40.tar.bz2
gentoo-4e5a338036457d556976a99be3f77aa4209bab40.zip
dev-haskell/hslua: bump up to 1.1.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hslua/Manifest1
-rw-r--r--dev-haskell/hslua/hslua-1.1.2.ebuild49
-rw-r--r--dev-haskell/hslua/metadata.xml10
3 files changed, 53 insertions, 7 deletions
diff --git a/dev-haskell/hslua/Manifest b/dev-haskell/hslua/Manifest
index d37196f3d47d..8b539a46607c 100644
--- a/dev-haskell/hslua/Manifest
+++ b/dev-haskell/hslua/Manifest
@@ -1 +1,2 @@
DIST hslua-1.0.3.1.tar.gz 236734 BLAKE2B 45eba849c41a22fdc7d03729f0ac15fb25ff83d1cdcb905a58a5813ef34f3b2e2a98a7ff2991083672a7afd5898e50e6ef9c83157c773b9861bd1547f4da5972 SHA512 047bcf851727e7525f10f6c705ec8968f330373aedf22bc91c96a44e5abdced46622a66a87c7973eac178c69dd3371bbcf4b858ed3c442719279e4cac4e57657
+DIST hslua-1.1.2.tar.gz 244832 BLAKE2B 5da2b9c2da6f43d841662b3143d3cd5b084d3f32cd2804316a8741e863d4c8dcab85da650b219af4250b2d4ec0570a742dc13b8bbeab79ec6dd5d4ddbe4907be SHA512 886a9d555a034b8fe74d5184457dad9e1bc9bd75662760a0415a75222bd64c556043ce6f98bc11dc1d27c34212f87ad3ce2271d5ff8125c1b5a89263cdf987eb
diff --git a/dev-haskell/hslua/hslua-1.1.2.ebuild b/dev-haskell/hslua/hslua-1.1.2.ebuild
new file mode 100644
index 000000000000..829469faf3e7
--- /dev/null
+++ b/dev-haskell/hslua/hslua-1.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6
+#hackport: flags: -allow-unsafe-gc,-apicheck,-export-dynamic,-lua501,-lua502,-lua_32bits,-system-lua,-pkg-config
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Lua language interpreter embedding in Haskell"
+HOMEPAGE="https://hslua.github.io/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardcode-reg-keys"
+
+RDEPEND=">=dev-haskell/base-compat-0.10:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-5:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-allow-unsafe-gc \
+ --flag=-apicheck \
+ --flag=-export-dynamic \
+ $(cabal_flag hardcode-reg-keys hardcode-reg-keys) \
+ --flag=-lua501 \
+ --flag=-lua502 \
+ --flag=-lua_32bits \
+ --flag=-pkg-config \
+ --flag=-system-lua
+}
diff --git a/dev-haskell/hslua/metadata.xml b/dev-haskell/hslua/metadata.xml
index a76459888050..6ca237e1273d 100644
--- a/dev-haskell/hslua/metadata.xml
+++ b/dev-haskell/hslua/metadata.xml
@@ -5,11 +5,7 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The Scripting.Lua module is a wrapper of Lua language interpreter
- as described in www.lua.org.
-
- The package is standalone: full Lua interpreter version 5.1.4
- is distributed in this package as well.
- </longdescription>
+ <use>
+ <flag name="hardcode-reg-keys">Don't use CAPI to determine the names of certain registry key names but Use hard coded values for instead. This flag is required when compiling against Lua 5.3.3 or earlier, as those do not expose the necessary information in the @lauxlib.h@ header file.</flag>
+ </use>
</pkgmetadata>