summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-11-16 22:44:58 -0700
committerSam James <sam@gentoo.org>2023-11-19 18:32:41 +0000
commit699415c7e8149e1029a50182dd026e5c7cd46928 (patch)
tree6c3e8860561cb568f15f9c2ac65db7db3ab8047d /dev-haskell
parentapp-portage/hackport: Add upper bound to ghc dep (diff)
downloadgentoo-699415c7e8149e1029a50182dd026e5c7cd46928.tar.gz
gentoo-699415c7e8149e1029a50182dd026e5c7cd46928.tar.bz2
gentoo-699415c7e8149e1029a50182dd026e5c7cd46928.zip
dev-haskell/hdbc: Fix dependencies
Add missing src_configure to pass needed flags. Loosen constraint on 'time'. This allows hdbc-2.4.0.3 to be built on newer GHC. Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdbc/hdbc-2.4.0.3.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild b/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
index 16d3945d0c86..858dae90cb35 100644
--- a/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
+++ b/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild
@@ -23,6 +23,10 @@ IUSE=""
RESTRICT="test" # Requires unmaintaned dev-haskell/testpack
+CABAL_CHDEPS=(
+ 'time >= 1.5 && < 1.10' 'time >= 1.5'
+)
+
RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/old-locale:=[profile?]
@@ -36,3 +40,13 @@ DEPEND="${RDEPEND}
"
S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ config_flags=(
+ --flag=-buildtests
+ --flag=splitBase
+ --flag=minTime15
+ )
+
+ haskell-cabal_src_configure ${config_flags[@]}
+}