summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-11 10:39:49 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-11 11:01:29 +0100
commit6d639f7e685a8cc4b378d23364ec874407da7f39 (patch)
tree12c55e0b167085a71352554ee0bdacd048589e66 /dev-haskell
parentdev-haskell/icalendar: iCalendar parser and printer library, a depend of app-... (diff)
downloadgentoo-6d639f7e685a8cc4b378d23364ec874407da7f39.tar.gz
gentoo-6d639f7e685a8cc4b378d23364ec874407da7f39.tar.bz2
gentoo-6d639f7e685a8cc4b378d23364ec874407da7f39.zip
dev-haskell/ac-ppm: PPM image writer, a depend of app-forensics/quickfuzz
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/ac-ppm/Manifest1
-rw-r--r--dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild30
-rw-r--r--dev-haskell/ac-ppm/metadata.xml20
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/ac-ppm/Manifest b/dev-haskell/ac-ppm/Manifest
new file mode 100644
index 000000000000..92d077ed1738
--- /dev/null
+++ b/dev-haskell/ac-ppm/Manifest
@@ -0,0 +1 @@
+DIST AC-PPM-1.1.1.tar.gz 2958 SHA256 783e93443321e5a1a1fcb63ee266bd21b9f2daf0b2bed8e6cfa0746a1dff5c78 SHA512 c296cb02fa9d70ca1f75bfdda8e307f66c800ac0e7b110bdd4af685c6acc506f3310456519d2445f850263baa22aa317266c68166bfcb551d297296d8c4de5ef WHIRLPOOL 182331ab2e10fd4b5a812d8decd1c9ae03af68a6bbadfdac951b15156e0b09a04f213813d47a805197149386090b2d8113e8a17ba8578bec44f6170dcd8cc2c6
diff --git a/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild b/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild
new file mode 100644
index 000000000000..41bcfcec77a9
--- /dev/null
+++ b/dev-haskell/ac-ppm/ac-ppm-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="AC-PPM"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Trivial package for writing PPM images"
+HOMEPAGE="http://hackage.haskell.org/package/AC-PPM"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/ac-ppm/metadata.xml b/dev-haskell/ac-ppm/metadata.xml
new file mode 100644
index 000000000000..435999615a27
--- /dev/null
+++ b/dev-haskell/ac-ppm/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package is written in 100% Haskell and enables you to
+ write PPM (\&quot;Portable Pixel Map\&quot;) images in human-readable
+ text format as well as the more efficient binary format.
+ It uses the ByteString library for maximum efficiency.
+ For those that don&#39;t know, PPM is an image file format
+ which is trivially simple, but therefore horribly inefficient.
+ None the less, many programs can read PPM files, so this
+ package represents an easy way to write Haskell code that
+ generates images, without having to depend on any external
+ C code.
+ </longdescription>
+</pkgmetadata>