summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-02 10:05:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-02 10:06:08 +0100
commite10fd2fc5d48def901899220caf6bc826ff9d214 (patch)
tree288f15c004d7ae71454c626b6f4d582780b5b903 /dev-haskell
parentapp-admin/exo: remove old (diff)
downloadgentoo-e10fd2fc5d48def901899220caf6bc826ff9d214.tar.gz
gentoo-e10fd2fc5d48def901899220caf6bc826ff9d214.tar.bz2
gentoo-e10fd2fc5d48def901899220caf6bc826ff9d214.zip
dev-haskell/happy: revert "drop old"
This reverts commit 741f647b14abffbed96096460d72efd341d4b2fc. Dropped latest version by accident. Noticed by dwfreed Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/happy/Manifest2
-rw-r--r--dev-haskell/happy/happy-1.19.12.ebuild69
-rw-r--r--dev-haskell/happy/happy-1.19.4.ebuild66
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-haskell/happy/Manifest b/dev-haskell/happy/Manifest
index cc64de9debf1..1bbc723221e9 100644
--- a/dev-haskell/happy/Manifest
+++ b/dev-haskell/happy/Manifest
@@ -1 +1,3 @@
+DIST happy-1.19.12.tar.gz 183254 BLAKE2B 17b0d30f4aaf194a0e36c06bd6349665c704b5ab61dce16cae47f0ca6bfef0a0e2d4bbf3456f47cebf0f71f1a0b4a59ff6b581cb4ff76a26d82573eb0e7b056a SHA512 20f36b17adf7330852fd4c05335adbf31e6f19907b4ec247c85a40ee1f8496c6dc432055026696906b149cec7f982b88c9a2eeedf14a11d34b1f6f73272e5208
+DIST happy-1.19.4.tar.gz 160497 BLAKE2B a8a271ea69100d24b9a293d53e2a3262ad34c26cc9b511648cf64df719c49936b5badc6651191ca52b48ed96660335e86e706763e186f5275de1b58ae528631c SHA512 d49893098f9982321fc03dad464bf787873a1a82167165d53f617ba04923c7e5d8f177def7fa045a5669d1c7f886a88087ba8f668ef1900a71498b5800cc4b1a
DIST happy-1.19.5.tar.gz 159280 BLAKE2B 5cfbddd981d689cfd076367e49f5b9fcfa38eca071a3d1d347a2074eb9c56436f6c7169d524b6628228472ee31ae1ccce3b5e1bcd0ae2b70d31283e3b4e33ee8 SHA512 7b43ef5236bdfba82bbddedb7edc7a8094990a389c0d3f5f848cb6208c3577e7b394cb290e51a2b2eebca25c97978a85ee932e74bbf6a792e261e5b5bff25a2b
diff --git a/dev-haskell/happy/happy-1.19.12.ebuild b/dev-haskell/happy/happy-1.19.12.ebuild
new file mode 100644
index 000000000000..c67b77e14afb
--- /dev/null
+++ b/dev-haskell/happy/happy-1.19.12.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: +small_base
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="https://www.haskell.org/happy/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-haskell/mtl-2.2.1:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ default
+
+ if use doc; then
+ cd doc || die
+ eautoconf
+ fi
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure \
+ --with-happy=false\
+ --flag=small_base
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/happy/.
+ doman doc/happy.1
+ fi
+}
diff --git a/dev-haskell/happy/happy-1.19.4.ebuild b/dev-haskell/happy/happy-1.19.4.ebuild
new file mode 100644
index 000000000000..40f68d3e3028
--- /dev/null
+++ b/dev-haskell/happy/happy-1.19.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit eutils haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="https://www.haskell.org/happy/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/mtl-1.0
+ >=dev-lang/ghc-6.10.4
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ for f in AttrGrammarParser Parser; do
+ # drop broken autogenerated
+ mv "dist/build/happy/happy-tmp/$f.hs" src/ || die
+ # drop depend on itself, otherwise cabal tries to regenerate it
+ rm "src/$f.ly" || die
+ done
+ use doc && cd doc && eautoconf
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure --with-happy=false
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use doc; then
+ cd doc || die
+ dohtml -r happy/*
+ doman "${S}/doc/happy.1"
+ fi
+}