summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-15 21:06:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 22:32:57 +0000
commite22a1f7c6d9cc0525a374e9b257d200843472026 (patch)
tree0e849d3db44bbf9b67bbd4e21f7fc3a4ba452e58 /dev-haskell
parentdev-haskell/th-utilities: bump up to 0.2.4.1 (diff)
downloadgentoo-e22a1f7c6d9cc0525a374e9b257d200843472026.tar.gz
gentoo-e22a1f7c6d9cc0525a374e9b257d200843472026.tar.bz2
gentoo-e22a1f7c6d9cc0525a374e9b257d200843472026.zip
dev-haskell/cabal: bump up to 3.2.1.0
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cabal/Manifest1
-rw-r--r--dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild54
-rw-r--r--dev-haskell/cabal/metadata.xml8
3 files changed, 55 insertions, 8 deletions
diff --git a/dev-haskell/cabal/Manifest b/dev-haskell/cabal/Manifest
index d1a7a7a8108d..ac7dbabfe313 100644
--- a/dev-haskell/cabal/Manifest
+++ b/dev-haskell/cabal/Manifest
@@ -1 +1,2 @@
DIST Cabal-3.0.1.0.tar.gz 758808 BLAKE2B 9a0cf7b055be4d6fa55c4dd44037263df54eff059cd22970383ffa1470317cdaeac8d81a521f8c48cf595fc22e64da031d508f6d2b58f32a613160b3e0cfcd67 SHA512 29a5ae9bad0398ab86c64cba9fb1ae3094d67013151a91c8c25b0e95b08d8fd683d1e85b064f7faf166966f855b261d2f131b727c82476a8514119a8922a6b06
+DIST Cabal-3.2.1.0.tar.gz 823331 BLAKE2B 060f4808010f9eefd943312144c75e021bf02083c2a0805128da6c9b93da94ba13fe37cef1fbe27e41fe8a10610e088b923783f4b7bb57150532d3a3ea4a91fc SHA512 279088a2ab9145efc03dbdd10941edcf6034137046ee3b659a8cf0ff075a03e3edff28fd01d432d39701c5a7e05a50b99cf8de95f05d3bd4e75edb3af0e3a598
diff --git a/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild b/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild
new file mode 100644
index 000000000000..d18123f7001e
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.2.1.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bundled-binary-generic
+
+# Drop test-suite due to "circular" dependencies with quickcheck
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="https://www.haskell.org/cabal/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" # ~ppc ~ppc64 ~ppc-macos ~x86-macos ~x86-solaris
+IUSE=""
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+# GHC lower bound set to 8.0 to remove semigroups and fail dependencies.
+RDEPEND=" >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-8.0:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ # Cabal bootstraps with 'ghc --make' without package cleanup in environment.
+ # That causes module collisions at build:
+ # - pulseaudio: Distribution/Utils/Structured.hs:98:1: error: Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.9.3
+ # - kinds: Distribution/Utils/Structured.hs:106:1: error: Ambiguous module name ‘Data.Kind’: it was found in multiple packages: base-4.14.1.0 kinds-0.0.1.5
+ HCFLAGS="${HCFLAGS} -ignore-package=pulseaudio"
+ HCFLAGS="${HCFLAGS} -ignore-package=kinds"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bundled-binary-generic
+}
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.3 PM:8.10.4 PM:9999"
diff --git a/dev-haskell/cabal/metadata.xml b/dev-haskell/cabal/metadata.xml
index 97bee0727e40..b7878815d80d 100644
--- a/dev-haskell/cabal/metadata.xml
+++ b/dev-haskell/cabal/metadata.xml
@@ -5,12 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The Haskell Common Architecture for Building Applications and
- Libraries: a framework defining a common interface for authors to more
- easily build their Haskell applications in a portable way.
-
- The Haskell Cabal is part of a larger infrastructure for distributing,
- organizing, and cataloging Haskell libraries and tools.
- </longdescription>
</pkgmetadata>