summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-11-11 21:09:49 -0700
committerSam James <sam@gentoo.org>2023-11-19 18:32:35 +0000
commitedc1c53d43c2c7ae963ffc0df2d26fcc474c8322 (patch)
tree932fa433e432650331d116e6802a9d9f0f0963ab /dev-haskell
parentdev-haskell/lifted-async: Hackage revision bump (diff)
downloadgentoo-edc1c53d43c2c7ae963ffc0df2d26fcc474c8322.tar.gz
gentoo-edc1c53d43c2c7ae963ffc0df2d26fcc474c8322.tar.bz2
gentoo-edc1c53d43c2c7ae963ffc0df2d26fcc474c8322.zip
dev-haskell/shelly: Hackage revision bump
Loosen constraint on 'time'. This allows shelly-1.9.0 to be built on newer GHC. Pulls latest Hackage revision for v1.9.0 Rename example executables to help avoid file collisions Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/shelly/Manifest1
-rw-r--r--dev-haskell/shelly/shelly-1.9.0.ebuild45
2 files changed, 39 insertions, 7 deletions
diff --git a/dev-haskell/shelly/Manifest b/dev-haskell/shelly/Manifest
index 4a9ca3c40042..e2d9257f7cd5 100644
--- a/dev-haskell/shelly/Manifest
+++ b/dev-haskell/shelly/Manifest
@@ -1,2 +1,3 @@
DIST shelly-1.12.1.tar.gz 75543 BLAKE2B db34e1a5e708192458e5d228b4758aa26812a3f547e39981754f8e3bb7af521c3887fde8e1b859a69b82edafc70be9979af30c918232a15e842f4e9894ed54ee SHA512 3917a03a23e61d5618f897f0ee90a4823980239252f260312ca86c7b364459c58749400e50a0f2ab78822c2eb6283891f993d2f31f0048a3cece19d5c565f05f
+DIST shelly-1.9.0-rev3.cabal 5393 BLAKE2B de11c00ff84352212cbc1d0a238c71686feb10fbe503b0eeda3912c50693d756499b75c779d637a2a171cf15b92a518ce51821c46b72d2dc6af78f513b6a3679 SHA512 f7ebde25f2132b0e4658467001b667f9b6239a609120177312fc849ae60c00d1dabea73c4c3596fe034eb318200004b225757ab095a20ebc98a0cdd678d96a97
DIST shelly-1.9.0.tar.gz 73344 BLAKE2B f12e8835be5dd648427ff92b73bc9a37215a47067e65456c4c3dc8e9c2e5bb610da171648aadf9759e9a91eb075fa74d06241f83977a5380f49bc861643707cc SHA512 7c1eb25439e08095187746d0101fd92ad56ebb5a706820bad7330667cfc806066d4675c677e5d267440d4af7b517f36449e8f5e75332521780b564edc1586254
diff --git a/dev-haskell/shelly/shelly-1.9.0.ebuild b/dev-haskell/shelly/shelly-1.9.0.ebuild
index 03d0f05b45c7..9d511cbf704a 100644
--- a/dev-haskell/shelly/shelly-1.9.0.ebuild
+++ b/dev-haskell/shelly/shelly-1.9.0.ebuild
@@ -3,43 +3,74 @@
EAPI=8
-# ebuild generated by hackport 0.6.1.9999
+# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: build-examples:examples
+CABAL_HACKAGE_REVISION=3
+
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="shell-like (systems) programming in Haskell"
-HOMEPAGE="https://github.com/gregwebs/Shelly.hs"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="examples lifted"
+CABAL_CHDEPS=(
+ 'time >= 1.3 && < 1.10' 'time >=1.3'
+)
+
RDEPEND="dev-haskell/async:=[profile?]
dev-haskell/enclosed-exceptions:=[profile?]
- >=dev-haskell/exceptions-0.6:=[profile?]
dev-haskell/lifted-async:=[profile?]
dev-haskell/lifted-base:=[profile?]
>=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
- >=dev-haskell/mtl-2:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/transformers-base:=[profile?]
<dev-haskell/unix-compat-0.6:=[profile?]
- >=dev-lang/ghc-8.0.2:=
+ >=dev-lang/ghc-9.0.2:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.2.0
+ >=dev-haskell/cabal-3.4.1.0
test? ( >=dev-haskell/hspec-2.0
dev-haskell/hspec-contrib
>=dev-haskell/hunit-1.2
>=dev-haskell/text-0.11 )
"
+example_exes=(
+ "drain"
+ "run-handles"
+ "Color"
+)
+
+src_prepare() {
+ for e in "${example_exes[@]}"; do
+ export CABAL_CHDEPS+=(
+ "Executable ${e}"
+ "executable ${PN}-examples-${e}"
+ )
+ done
+
+ haskell-cabal_src_prepare
+}
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag examples build-examples) \
$(cabal_flag lifted lifted)
}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+
+ elog "The following example executables installed with this package have been"
+ elog "renamed to help prevent name collisions:"
+
+ for e in "${example_exes[@]}"; do
+ elog "${e} -> ${PN}-examples-${e}"
+ done
+}