summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-09-12 23:47:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-12 23:47:33 +0100
commitf0f26025bbb9fd67a7e0d7a9932eafb31080e9b2 (patch)
tree3fa0c00206333f303a8c6264a1c5f9551f0d819a /dev-haskell
parentdev-haskell/vault: drop old (diff)
downloadgentoo-f0f26025bbb9fd67a7e0d7a9932eafb31080e9b2.tar.gz
gentoo-f0f26025bbb9fd67a7e0d7a9932eafb31080e9b2.tar.bz2
gentoo-f0f26025bbb9fd67a7e0d7a9932eafb31080e9b2.zip
dev-haskell/vector-algorithms: drop old
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/vector-algorithms/Manifest2
-rw-r--r--dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch44
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild40
-rw-r--r--dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild40
4 files changed, 0 insertions, 126 deletions
diff --git a/dev-haskell/vector-algorithms/Manifest b/dev-haskell/vector-algorithms/Manifest
index 95ffba10192d..eb43644ef7e5 100644
--- a/dev-haskell/vector-algorithms/Manifest
+++ b/dev-haskell/vector-algorithms/Manifest
@@ -1,3 +1 @@
-DIST vector-algorithms-0.6.0.4.tar.gz 20455 BLAKE2B 0d0c4ef7ed8996d1ebe65971a451d4cb49118faedbf9cb4a987afb281adf563808778a689df608d2fb3c8fe9398af995d1c5e31cc89fd4f2075c2ebdd7ca4277 SHA512 5e99a77771831f0b9a4485f48aa7be5f5928e811512f0a68e18fa65ecace185dfea74ec09037b05d56e1a9208d2cdbcfed94ce2678d504f6d12267496a3616bf
-DIST vector-algorithms-0.7.0.1.tar.gz 25435 BLAKE2B f9cb3bf592316c92bff4313d264370cc35d62c64e7dec6f14ee9954c0fc12f573e799172793501e1b4f9c556fa1ea8e3db1ac3381ff71bb143e33520c69c18b8 SHA512 1ea718eeb062defee830fa7dba323981678691c5d320b8929dcd695af17f82d65007cfd35103310026dab51cf10462dbead09082fc0ba5ddd0c2e18e305c4c6a
DIST vector-algorithms-0.8.0.3.tar.gz 26559 BLAKE2B 7541d141967faf4bc1b33dcd23f283e1a6868f0b51e784918c1516a46c38ba3e9205045c87679738d89c48fee3ee2e61286eab59cc66ec8cfc18f1a4b977c634 SHA512 45311e19a1e5c9994e7d666b73445d11946f60915df3d2f385a435538d1b6b0929b56a960f83c5df1b2df883566e7f8e6fdd5be4e075364d7daecd6dbec780e5
diff --git a/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch b/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
deleted file mode 100644
index 3616dd76d82c..000000000000
--- a/dev-haskell/vector-algorithms/files/vector-algorithms-0.7.0.1-ghc-8.0.2_rc1.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/tests/properties/Tests.hs b/tests/properties/Tests.hs
-index a0b7d35..8fcfd36 100644
---- a/tests/properties/Tests.hs
-+++ b/tests/properties/Tests.hs
-@@ -1,2 +1,2 @@
--{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts #-}
-+{-# LANGUAGE ImpredicativeTypes, RankNTypes, TypeOperators, FlexibleContexts, ScopedTypeVariables #-}
-
-@@ -44,4 +44,4 @@ args = stdArgs
-
--check_Int_sort = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_fullsort algo)
-+check_Int_sort = forM_ algos (\(name,algo :: Algo Int ()) ->
-+ quickCheckWith args (label name . prop_fullsort algo))
- where
-@@ -55,4 +55,4 @@ check_Int_sort = forM_ algos $ \(name,algo) ->
-
--check_Int_partialsort = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_partialsort algo)
-+check_Int_partialsort = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
-+ quickCheckWith args (label name . prop_partialsort algo))
- where
-@@ -63,4 +63,4 @@ check_Int_partialsort = forM_ algos $ \(name,algo) ->
-
--check_Int_select = forM_ algos $ \(name,algo) ->
-- quickCheckWith args (label name . prop_select algo)
-+check_Int_select = forM_ algos (\(name,algo :: SizeAlgo Int ()) ->
-+ quickCheckWith args (label name . prop_select algo))
- where
-@@ -119,10 +119,10 @@ check_permutation = do
- qc $ label "introsort" . prop_permutation (INT.sort :: Algo Int ())
-- qc $ label "intropartial" . prop_sized (const . prop_permutation)
-+ qc $ label "intropartial" . prop_sized (\x -> const (prop_permutation x))
- (INT.partialSort :: SizeAlgo Int ())
-- qc $ label "introselect" . prop_sized (const . prop_permutation)
-+ qc $ label "introselect" . prop_sized (\x -> const (prop_permutation x))
- (INT.select :: SizeAlgo Int ())
- qc $ label "heapsort" . prop_permutation (H.sort :: Algo Int ())
-- qc $ label "heappartial" . prop_sized (const . prop_permutation)
-+ qc $ label "heappartial" . prop_sized (\x -> const (prop_permutation x))
- (H.partialSort :: SizeAlgo Int ())
-- qc $ label "heapselect" . prop_sized (const . prop_permutation)
-+ qc $ label "heapselect" . prop_sized (\x -> const (prop_permutation x))
- (H.select :: SizeAlgo Int ())
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild
deleted file mode 100644
index 60de2b4a02fb..000000000000
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.6.0.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.4.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient algorithms for vector arrays"
-HOMEPAGE="http://code.haskell.org/~dolio/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bench +boundschecks internalchecks +properties unsafechecks"
-
-RESTRICT=test # hangs
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/mwc-random:=[profile?]
- >=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.9.2
- test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bench bench) \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag properties properties) \
- $(cabal_flag unsafechecks unsafechecks)
-}
diff --git a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild b/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
deleted file mode 100644
index 9a143ddec1ca..000000000000
--- a/dev-haskell/vector-algorithms/vector-algorithms-0.7.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Efficient algorithms for vector arrays"
-HOMEPAGE="http://code.haskell.org/~dolio/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="bench +boundschecks internalchecks +properties unsafechecks"
-
-RDEPEND="dev-haskell/mtl:=[profile?]
- dev-haskell/mwc-random:=[profile?]
- >=dev-haskell/primitive-0.3:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
- >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.12:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.9.2
- test? ( properties? ( >=dev-haskell/quickcheck-2 ) )
-"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch)
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag bench bench) \
- $(cabal_flag boundschecks boundschecks) \
- $(cabal_flag internalchecks internalchecks) \
- $(cabal_flag properties properties) \
- $(cabal_flag unsafechecks unsafechecks)
-}