summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant-contrib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant-contrib')
-rw-r--r--dev-java/ant-contrib/Manifest2
-rw-r--r--dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild61
-rw-r--r--dev-java/ant-contrib/ant-contrib-1.0_beta3-r1.ebuild78
-rw-r--r--dev-java/ant-contrib/files/tests-visibility.patch12
-rw-r--r--dev-java/ant-contrib/metadata.xml8
5 files changed, 161 insertions, 0 deletions
diff --git a/dev-java/ant-contrib/Manifest b/dev-java/ant-contrib/Manifest
new file mode 100644
index 000000000000..5b36966779dc
--- /dev/null
+++ b/dev-java/ant-contrib/Manifest
@@ -0,0 +1,2 @@
+DIST ant-contrib-1.0b2-src.tar.bz2 118216 SHA256 29bdd00ee0df1d7b24e55b08bfff5641edf3f805e45a278641d42c0bf0ce9269 SHA512 5245ed1458c9c4892ab8196a8acdf8678aab0d45fc58fcd8ca446e3589f378a9a02de8e608abb75d24fa190cdcbe209454a703eec8d4e563b7690d6d58ea9af8 WHIRLPOOL 3247772090ab6b1cab556c0b4442ad4ecc4a9f15b7ffb6117f8c8f95ac4267215a741f3ecb45ed335657f1e881a933b1f3cf607a34602834fe7bdb37b30ccf65
+DIST ant-contrib-1.0b3-src.tar.bz2 3298187 SHA256 5c180feaca2704d914054a1e6b453673cc9b65cfb3da307aff17439a9aa09d6b SHA512 8147ed51612eed9d41515c00ef2bb7210ebd50dba8b471abfadf8a56c67b53c030602ce9e49e9070d72d383de61f290e941a76c282e223330fee606f3633b0a8 WHIRLPOOL e87fe9d07a97a1a8ccf4f4d0984f02ab967c5b8f6a11d6171f235fa3b9fa243dc7243953d9b14e72cbfece91d41ac264babee0241429090b1868e948a855fd3e
diff --git a/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild b/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild
new file mode 100644
index 000000000000..1604cd90ba45
--- /dev/null
+++ b/dev-java/ant-contrib/ant-contrib-1.0_beta2-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A collection of tasks (and at one point maybe types and other tools) for Apache Ant"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${PN}-${PV/_beta/b}-src.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+# test? ( dev-java/ant-junit dev-java/ant-testutil )
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/bcel-5.1
+ >=dev-java/xerces-2.7
+ >=dev-java/ant-core-1.7.0"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/tests-visibility.patch"
+ cd "${S}/lib"
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from bcel bcel.jar bcel-5.1.jar
+ java-pkg_jar-from xerces-2
+}
+
+EANT_EXTRA_ARGS="-Dversion=${PV} -Ddep.available=true"
+EANT_DOC_TARGET="docs"
+
+# The tests fail to find bcel and fail
+RESTRICT="test"
+
+src_test() {
+ cd test/lib || die
+ java-pkg_jar-from junit junit.jar junit-3.8.1.jar
+ java-pkg_jar-from ant-testutil
+ cd "${S}"
+ local testutil=$(java-pkg_getjars ant-testutil)
+ EANT_TEST_EXTRA_ARGS="-Dtestutil.jar.location=${testutil}" \
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ java-pkg_register-ant-task
+ dodoc README.txt || die
+ use doc && java-pkg_dojavadoc build/docs/api
+ use source && java-pkg_dosrc src/net
+ java-pkg_dohtml -r manual
+}
diff --git a/dev-java/ant-contrib/ant-contrib-1.0_beta3-r1.ebuild b/dev-java/ant-contrib/ant-contrib-1.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..2cfb3264a294
--- /dev/null
+++ b/dev-java/ant-contrib/ant-contrib-1.0_beta3-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+WANT_ANT_TASKS="ant-ivy"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A collection of tasks (and at one point maybe types and other tools) for Apache Ant"
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${PN}-${PV/_beta/b}-src.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+
+# test? ( dev-java/ant-junit dev-java/ant-testutil )
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/bcel-5.1:0
+ dev-java/commons-httpclient:3
+ dev-java/xerces:2
+ dev-java/ant-ivy:0
+ >=dev-java/ant-core-1.7.0"
+
+# javatoolkit for cElementTree
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/javatoolkit-0.3.0-r2
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+rewrite_build_xml() {
+ python <<EOF
+import xml.etree.cElementTree as et
+tree = et.ElementTree(file='build.xml')
+root = tree.getroot()
+root.append(et.Element('path',id='test.classpath'))
+root.append(et.Element('path',id='compile.classpath'))
+skip=['resolve','classpath']
+for target in tree.getiterator("target"):
+ if target.attrib['name'] in skip:
+ target.attrib['if'] = 'false'
+
+tree.write('build.xml')
+EOF
+ [[ $? != 0 ]] && die "Removing taskdefs failed"
+}
+
+java_prepare() {
+ epatch "${FILESDIR}/tests-visibility.patch"
+
+ find . -name "*.jar" -print -delete || die
+
+ rewrite_build_xml
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="ant-core,bcel,commons-httpclient-3,xerces-2,ant-ivy"
+EANT_EXTRA_ARGS="-Dversion=${PV} -Ddep.available=true"
+
+# Can't load bcel for some reason
+RESTRICT="test"
+# for tests
+EANT_GENTOO_CLASSPATH_EXTRA="target/${PN}.jar"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ java-pkg_register-ant-task
+
+ use doc && java-pkg_dojavadoc target/docs/api
+ use source && java-pkg_dosrc src/java/net
+
+ java-pkg_dohtml -r docs/manual
+}
diff --git a/dev-java/ant-contrib/files/tests-visibility.patch b/dev-java/ant-contrib/files/tests-visibility.patch
new file mode 100644
index 000000000000..182a17f054e0
--- /dev/null
+++ b/dev-java/ant-contrib/files/tests-visibility.patch
@@ -0,0 +1,12 @@
+diff -ur ant-contrib.old/test/src/net/sf/antcontrib/BuildFileTestBase.java ant-contrib/test/src/net/sf/antcontrib/BuildFileTestBase.java
+--- ant-contrib.old/test/src/net/sf/antcontrib/BuildFileTestBase.java 2008-03-05 23:56:16.000000000 +0200
++++ ant-contrib/test/src/net/sf/antcontrib/BuildFileTestBase.java 2008-03-05 23:56:55.000000000 +0200
+@@ -76,7 +76,7 @@
+ * @param filename name of project file to run
+ * @exception BuildException Description of the Exception
+ */
+- protected void configureProject( String filename ) throws BuildException {
++ public void configureProject( String filename ) throws BuildException {
+ // find the build file
+ File f = new File( filename );
+ if ( !f.exists() ) {
diff --git a/dev-java/ant-contrib/metadata.xml b/dev-java/ant-contrib/metadata.xml
new file mode 100644
index 000000000000..9452de6d1452
--- /dev/null
+++ b/dev-java/ant-contrib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">ant-contrib</remote-id>
+ </upstream>
+</pkgmetadata>