summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-11-24 11:28:53 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-11-24 11:30:40 +0100
commit5970177a7d79ad3192129f7244d3a3a26d4366d0 (patch)
tree3e43770446b6f20131425668de17ca7dd02d6aa4 /dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild
parentdev-java/eclipse-ecj: bump to 4.15 (diff)
downloadgentoo-5970177a7d79ad3192129f7244d3a3a26d4366d0.tar.gz
gentoo-5970177a7d79ad3192129f7244d3a3a26d4366d0.tar.bz2
gentoo-5970177a7d79ad3192129f7244d3a3a26d4366d0.zip
dev-java/ant-eclipse-ecj: bump to 4.15
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild')
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild
new file mode 100644
index 000000000000..27aab2586f93
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple prefix
+
+DMF="R-${PV}-202003050155"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF}/ecjsrc-${PV}.jar"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="4.15"
+IUSE=""
+
+CDEPEND="~dev-java/eclipse-ecj-${PV}:${SLOT}
+ dev-java/ant-core:0"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-11"
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-11"
+
+JAVA_GENTOO_CLASSPATH="ant-core,eclipse-ecj-${SLOT}"
+
+src_prepare() {
+ default
+
+ # Remove everything but the Ant component.
+ find org -type f ! -path "org/eclipse/jdt/internal/antadapter/*" ! -name "JDTCompilerAdapter.java" -delete || die
+
+ rm build.xml || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ find org -type f ! -name "*.java" | xargs jar uvf "${PN}.jar" || die "jar update failed"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ insinto /usr/share/java-config-2/compiler
+ doins "${FILESDIR}/ecj-${SLOT}"
+ eprefixify "${D}"/usr/share/java-config-2/compiler/ecj-${SLOT}
+}