summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-10-01 20:12:16 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-10-01 20:16:02 +0200
commit53be3bd16506cb70d9fcb6a63b68fc44c6972ffd (patch)
treea59e7c986d1c2d698076c44de82a0f8cdeed640f /dev-java/ant-junit4/ant-junit4-1.10.9.ebuild
parentdev-java/ant-junit: bump to 1.10.9 (diff)
downloadgentoo-53be3bd16506cb70d9fcb6a63b68fc44c6972ffd.tar.gz
gentoo-53be3bd16506cb70d9fcb6a63b68fc44c6972ffd.tar.bz2
gentoo-53be3bd16506cb70d9fcb6a63b68fc44c6972ffd.zip
dev-java/ant-junit4: bump to 1.10.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-junit4/ant-junit4-1.10.9.ebuild')
-rw-r--r--dev-java/ant-junit4/ant-junit4-1.10.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/ant-junit4/ant-junit4-1.10.9.ebuild b/dev-java/ant-junit4/ant-junit4-1.10.9.ebuild
new file mode 100644
index 000000000000..5dcdbe73523e
--- /dev/null
+++ b/dev-java/ant-junit4/ant-junit4-1.10.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ANT_TASK_JDKVER=1.8
+ANT_TASK_JREVER=1.8
+ANT_TASK_DEPNAME="junit-4"
+
+inherit ant-tasks
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="dev-java/junit:4
+ ~dev-java/ant-junit-${PV}"
+
+RDEPEND="${DEPEND}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="junit-4,ant-junit"
+
+src_prepare() {
+ default
+
+ java-pkg_jar-from --build-only --into "${S}/lib" ant-junit
+}
+
+src_install() {
+ # No registration as ant-task, would be loaded together with ant-junit.
+ java-pkg_dojar build/lib/ant-junit4.jar
+
+ # As we dont't want to depend on and-junit in package.env, because it depends
+ # on junit:0. Instead, we "steal" its jar and record it to our package.env as
+ # if it belongs to this package's classpath.
+ java-pkg_getjar --build-only ant-junit ant-junit.jar
+ java-pkg_regjar $(java-pkg_getjar --build-only ant-junit ant-junit.jar)
+}