summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-01-21 10:48:23 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-01-21 11:29:36 +0100
commitf46038ea53b86293ffa0dde0dacf9e1298a61ec2 (patch)
tree5b65269a893159c6f6885f23733200bccc110c4b /dev-java/ant-testutil/ant-testutil-1.9.13.ebuild
parentdev-java/ant-swing-1.9.13: bump (bug #571110) (diff)
downloadgentoo-f46038ea53b86293ffa0dde0dacf9e1298a61ec2.tar.gz
gentoo-f46038ea53b86293ffa0dde0dacf9e1298a61ec2.tar.bz2
gentoo-f46038ea53b86293ffa0dde0dacf9e1298a61ec2.zip
dev-java/ant-testutil-1.9.13: bump (bug #571110)
Package-Manager: Portage-2.3.57, Repoman-2.3.12 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/ant-testutil/ant-testutil-1.9.13.ebuild')
-rw-r--r--dev-java/ant-testutil/ant-testutil-1.9.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/ant-testutil/ant-testutil-1.9.13.ebuild b/dev-java/ant-testutil/ant-testutil-1.9.13.ebuild
new file mode 100644
index 000000000000..c29ef4f5b6f0
--- /dev/null
+++ b/dev-java/ant-testutil/ant-testutil-1.9.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ANT_TASK_JDKVER=1.8
+ANT_TASK_JREVER=1.8
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional test utility classes"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/ant-core:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.8
+ >=dev-java/junit-4.11:4
+ ~dev-java/ant-swing-${PV}
+ ~dev-java/ant-junit4-${PV}"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.8"
+
+# The build system builds much more than it actually packages, so there are many
+# build-only deps, but since those are quite common, it wasn't worth to patch it.
+
+src_unpack() {
+ ant-tasks_src_unpack base
+ java-pkg_jar-from --build-only junit-4,ant-junit4,ant-swing
+ java-pkg_jar-from --build-only ant-core ant-launcher.jar
+}
+
+src_compile() {
+ eant test-jar
+}