summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKaibo Ma <kaiboma06@gmail.com>2021-02-20 15:36:14 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-23 10:13:43 +0100
commita5db61dfb375fc90fe5846215f86346998c85229 (patch)
tree1357dce59a209205e62ac930a7b1f176dead40b7 /dev-java/asm/asm-9.1.ebuild
parentdev-java/commons-lang: bump to 3.11 (diff)
downloadgentoo-a5db61dfb375fc90fe5846215f86346998c85229.tar.gz
gentoo-a5db61dfb375fc90fe5846215f86346998c85229.tar.bz2
gentoo-a5db61dfb375fc90fe5846215f86346998c85229.zip
dev-java/asm{,-*}: new packages and version bumps
dev-java/asm bumped to the latest versions, because upstream doesn't publish asm-all anymore, we should also split it into components. The dependencies are as follows: - asm: no dependency - asm-tree: asm - asm-analysis: asm, asm-tree - asm-commons and asm-util: asm, asm-tree, asm-analysis Testing is still restricted because it uses JUnit 5 for testing. Signed-off-by: Kaibo Ma <kaiboma06@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19473 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/asm/asm-9.1.ebuild')
-rw-r--r--dev-java/asm/asm-9.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-java/asm/asm-9.1.ebuild b/dev-java/asm/asm-9.1.ebuild
new file mode 100644
index 000000000000..7ff100a3d930
--- /dev/null
+++ b/dev-java/asm/asm-9.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Bytecode manipulation framework for Java"
+HOMEPAGE="http://asm.ow2.org"
+MY_P="ASM_${PV//./_}"
+SRC_URI="https://gitlab.ow2.org/asm/asm/-/archive/${MY_P}/asm-${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="9"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+RESTRICT="test"
+
+CDEPEND=""
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+JAVA_SRC_DIR="asm-${MY_P}/${PN}/src/main/java"