summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-08 21:58:42 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-08 22:06:12 +0000
commitcf8fba71493e95cd4ec3d9aebf05083e2f54fcef (patch)
tree2359a06152370a043d571c0a43417aac85a64a22 /dev-java/bcprov/bcprov-1.45-r2.ebuild
parentdev-java/bcprov: Mend use test condition. (diff)
downloadgentoo-cf8fba71493e95cd4ec3d9aebf05083e2f54fcef.tar.gz
gentoo-cf8fba71493e95cd4ec3d9aebf05083e2f54fcef.tar.bz2
gentoo-cf8fba71493e95cd4ec3d9aebf05083e2f54fcef.zip
dev-java/bcprov: EAPI 5 bump. Point SRC_URI to a new URL as the former one is dead.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/bcprov/bcprov-1.45-r2.ebuild')
-rw-r--r--dev-java/bcprov/bcprov-1.45-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/bcprov/bcprov-1.45-r2.ebuild b/dev-java/bcprov/bcprov-1.45-r2.ebuild
new file mode 100644
index 000000000000..e1cc422f9c4c
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.45-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN}-jdk16"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://central.maven.org/maven2/org/bouncycastle/${MY_PN}/${PV}/${MY_P}-sources.jar"
+LICENSE="BSD"
+SLOT="1.45"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+CDEPEND=""
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+JAVA_ENCODING="ISO-8859-1"
+JAVA_SRC_DIR="org"
+
+# Package can't be built with test as bcprov and bcpkix can't be built with test.
+RESTRICT="test"
+
+java_prepare() {
+ if ! use test; then
+ # There are too many files to delete so we won't be using JAVA_RM_FILES
+ # (it produces a lot of output).
+ local RM_TEST_FILES=()
+ while read -d $'\0' -r file; do
+ RM_TEST_FILES+=("${file}")
+ done < <(find . -name "*Test*.java" -type f -print0)
+ while read -d $'\0' -r file; do
+ RM_TEST_FILES+=("${file}")
+ done < <(find . -name "*Mock*.java" -type f -print0)
+
+ rm -v "${RM_TEST_FILES[@]}"
+ fi
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ use source && java-pkg_dosrc org
+}