summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/bcprov/bcprov-1.52.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/bcprov/bcprov-1.52.ebuild')
-rw-r--r--dev-java/bcprov/bcprov-1.52.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/dev-java/bcprov/bcprov-1.52.ebuild b/dev-java/bcprov/bcprov-1.52.ebuild
new file mode 100644
index 000000000000..c2e5a3c31a5c
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.52.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Needs further investigation.
+# java.security.NoSuchAlgorithmException: Cannot find any provider supporting McElieceFujisakiWithSHA256
+RESTRICT="test"
+
+# The src_unpack find needs a new find
+# https://bugs.gentoo.org/show_bug.cgi?id=182276
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ userland_GNU? (
+ sys-apps/findutils
+ )
+ test? (
+ dev-java/junit:4
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+IUSE="userland_GNU"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+ cd "${S}" || die
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes || die
+
+ if use test; then
+ java-pkg_jar-from --build-only junit-4
+ fi
+}
+
+src_compile() {
+ find . -name "*.java" > "${T}"/src.list
+
+ local cp
+ if use test ; then
+ cp="-cp junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac $cp -encoding ISO-8859-1 -d "${S}"/classes "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.pqc.jcajce.provider.test.AllTests | tee pqc.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.ocsp.test.AllTests | tee oscp.tests
+ java -cp ${PN}.jar:junit.jar org.bouncycastle.jce.provider.test.AllTests | tee jce.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}