summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-12-15 06:38:35 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-12-15 09:43:03 +0100
commita17654958bbdacc757483cc98b512f81b63ad097 (patch)
tree8436fbe7a84c6e2f7e258d33a42260d52452a2c2 /dev-java/bcprov
parentdev-java/bcpkix: drop 1.71-r1 (diff)
downloadgentoo-a17654958bbdacc757483cc98b512f81b63ad097.tar.gz
gentoo-a17654958bbdacc757483cc98b512f81b63ad097.tar.bz2
gentoo-a17654958bbdacc757483cc98b512f81b63ad097.zip
dev-java/bcprov: drop 1.71-r1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/28669 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/bcprov')
-rw-r--r--dev-java/bcprov/Manifest1
-rw-r--r--dev-java/bcprov/bcprov-1.71-r1.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/dev-java/bcprov/Manifest b/dev-java/bcprov/Manifest
index a6beedad13a8..11f3fa328c20 100644
--- a/dev-java/bcprov/Manifest
+++ b/dev-java/bcprov/Manifest
@@ -1,2 +1 @@
-DIST bc-java-r1rv71.tar.gz 117684695 BLAKE2B db0a1b2576a55592e0447aa8734e8ecb6fe8452d08dabf010070f3c6b5a3b4caa7a5929baaa52796fed0ef397e18fe58fdb91dfef6da75af8f28efb627d2b808 SHA512 c9a095a034863a46027e28754ae96d9750162120bc1af124fa700ad05d23716a606633b674e2e8490bda658d30d30e93f42ba00dcc1ac13596a24f8aa43a666d
DIST bc-java-r1rv72.tar.gz 380374879 BLAKE2B 53c593c1d97e9ee56388479dce7386d254f74a8bab9612e802ebe963df84d1a397fe0c5a7a0d0db2ac2cd3252ae43e79c67b9d3ba1b5ffc20cc8727c7e1a6994 SHA512 dbfdd9e4f30ab713584830a0fd0d7e4f89904366bf4953a9e722656cc4cd92c9d29238649efa7b4cdab64e2c08f4b3b3c96667d1ade569ade5a5a2c9ad9d5b5c
diff --git a/dev-java/bcprov/bcprov-1.71-r1.ebuild b/dev-java/bcprov/bcprov-1.71-r1.ebuild
deleted file mode 100644
index fbe5c65f3f19..000000000000
--- a/dev-java/bcprov/bcprov-1.71-r1.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.bouncycastle:bcprov-jdk18on:1.71"
-JAVA_TESTING_FRAMEWORKS="junit-4"
-
-inherit java-pkg-2 java-pkg-simple check-reqs
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="https://www.bouncycastle.org/java.html"
-SRC_URI="https://github.com/bcgit/bc-java/archive/r${PV/./rv}.tar.gz -> bc-java-r${PV/./rv}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-DEPEND=">=virtual/jdk-11:*"
-RDEPEND=">=virtual/jre-1.8:*"
-BDEPEND="app-arch/zip"
-
-DOCS=( ../{README,SECURITY}.md )
-HTML_DOCS=( ../{CONTRIBUTORS,index}.html )
-
-S="${WORKDIR}/bc-java-r${PV/./rv}/prov"
-
-JAVA_SRC_DIR=(
- "src/main/java"
- "../core/src/main/java" # package org.bouncycastle.asn1 does not exist
- "src/main/jdk1.9" # https://bugs.gentoo.org/797634
-)
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-JAVA_TEST_GENTOO_CLASSPATH="junit-4"
-JAVA_TEST_SRC_DIR=( "src/test/java" "../core/src/test/java" )
-JAVA_TEST_RESOURCE_DIRS=( "src/test/resources" "../core/src/test/resources" )
-
-JAVA_TEST_EXTRA_ARGS="-Dbc.test.data.home=${S}/../core/src/test/data"
-
-# Depending on vm_version 11 or 17 there are 2 different errrors
-# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
-# junit.framework.AssertionFailedError: index 29 KeyStore: Exception: java.security.KeyStoreException: BKS-V1 not found
-# at junit.framework.Assert.fail(Assert.java:57)
-# at junit.framework.TestCase.fail(TestCase.java:223)
-# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
-#
-# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
-# junit.framework.AssertionFailedError: index 9 BlockCipher: IDEA/PGPCFB/NoPadding failed encryption - java.io.IOException: javax.crypto.ShortBufferException: output buffer too short for input.
-# at junit.framework.Assert.fail(Assert.java:57)
-# at junit.framework.TestCase.fail(TestCase.java:223)
-# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
-JAVA_TEST_RUN_ONLY=(
- "org.bouncycastle.asn1.test.AllTests"
- "org.bouncycastle.crypto.agreement.test.AllTests"
- "org.bouncycastle.crypto.ec.test.AllTests"
- "org.bouncycastle.crypto.prng.test.AllTests"
- "org.bouncycastle.crypto.test.AllTests"
- "org.bouncycastle.jcajce.provider.test.AllTests"
-# "org.bouncycastle.jce.provider.test.AllTests" # bug #827146
- "org.bouncycastle.jce.provider.test.nist.AllTests"
- "org.bouncycastle.jce.provider.test.rsa3.AllTests"
- "org.bouncycastle.pqc.crypto.lms.AllTests"
- "org.bouncycastle.pqc.crypto.test.AllTests"
- "org.bouncycastle.pqc.jcajce.provider.test.AllTests"
- "org.bouncycastle.util.encoders.test.AllTests"
-)
-
-check_env() {
- if use test; then
- # this is needed only for tests
- CHECKREQS_MEMORY="2048M"
- check-reqs_pkg_pretend
- fi
-}
-
-pkg_pretend() {
- check_env
-}
-
-pkg_setup() {
- check_env
- java-pkg-2_pkg_setup
-}
-
-src_prepare() {
- default
- java-pkg_clean ..
-}
-
-src_test() {
- JAVA_TEST_EXTRA_ARGS+=" -Xmx${CHECKREQS_MEMORY}"
- java-pkg-simple_src_test
-}
-
-src_install() {
- default
- einstalldocs
- docinto html
- dodoc -r ../docs
-
- # These files are not present in the upstream jar but are used for tests
- # Removing them from the jar file after testing
- zip --delete "${S}"/bcprov.jar \
- "org/bouncycastle/pqc/crypto/ntru/*" \
- "org/bouncycastle/pqc/math/ntru/*" \
- || die "cleaning after tests failed"
-
- java-pkg-simple_src_install
-}