summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-14 10:59:28 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-22 19:29:44 +0200
commitd3f91619efa65f2b9372c3735fe8c29e971bd799 (patch)
treedf338052b223faf78cabb141a25a4be908a7d52c /dev-java/bcprov
parentdev-java/jakarta-mail-api: new package (diff)
downloadgentoo-d3f91619efa65f2b9372c3735fe8c29e971bd799.tar.gz
gentoo-d3f91619efa65f2b9372c3735fe8c29e971bd799.tar.bz2
gentoo-d3f91619efa65f2b9372c3735fe8c29e971bd799.zip
dev-java/bcprov: add 1.71
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/bcprov')
-rw-r--r--dev-java/bcprov/Manifest1
-rw-r--r--dev-java/bcprov/bcprov-1.71.ebuild110
-rw-r--r--dev-java/bcprov/metadata.xml2
3 files changed, 112 insertions, 1 deletions
diff --git a/dev-java/bcprov/Manifest b/dev-java/bcprov/Manifest
index b7586bb46675..ead2869d65a6 100644
--- a/dev-java/bcprov/Manifest
+++ b/dev-java/bcprov/Manifest
@@ -1 +1,2 @@
DIST bc-java-r1rv69.tar.gz 56587177 BLAKE2B be5321f48911840de70d3201c0436cf4147a25999abb605dc4c176ea9292796ca25633635d66dccab685a4bb162258c4495ccc764782119a0750ec1b7456a7db SHA512 5224f424faf549e8e3f2db1134e74647b09bebb654ed23bb0bcd493f065fdb3f2b4f2815be0137ebcc9d62b25a6725b7a26b76d55eb3ad014ad0ce92961126de
+DIST bc-java-r1rv71.tar.gz 117684695 BLAKE2B db0a1b2576a55592e0447aa8734e8ecb6fe8452d08dabf010070f3c6b5a3b4caa7a5929baaa52796fed0ef397e18fe58fdb91dfef6da75af8f28efb627d2b808 SHA512 c9a095a034863a46027e28754ae96d9750162120bc1af124fa700ad05d23716a606633b674e2e8490bda658d30d30e93f42ba00dcc1ac13596a24f8aa43a666d
diff --git a/dev-java/bcprov/bcprov-1.71.ebuild b/dev-java/bcprov/bcprov-1.71.ebuild
new file mode 100644
index 000000000000..178f2c329d2c
--- /dev/null
+++ b/dev-java/bcprov/bcprov-1.71.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.bouncycastle:bcprov-jdk18on:1.71"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple check-reqs
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="https://www.bouncycastle.org/java.html"
+SRC_URI="https://github.com/bcgit/bc-java/archive/r${PV/./rv}.tar.gz -> bc-java-r${PV/./rv}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-11:*"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/zip"
+
+DOCS=( ../{README,SECURITY}.md )
+HTML_DOCS=( ../{CONTRIBUTORS,index}.html )
+
+S="${WORKDIR}/bc-java-r${PV/./rv}/prov"
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "../core/src/main/java" # package org.bouncycastle.asn1 does not exist
+ "src/main/jdk1.9" # https://bugs.gentoo.org/797634
+)
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR=( "src/test/java" "../core/src/test/java" )
+JAVA_TEST_RESOURCE_DIRS=( "src/test/resources" "../core/src/test/resources" )
+
+JAVA_TEST_EXTRA_ARGS="-Dbc.test.data.home=${S}/../core/src/test/data"
+
+# Depending on vm_version 11 or 17 there are 2 different errrors
+# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
+# junit.framework.AssertionFailedError: index 29 KeyStore: Exception: java.security.KeyStoreException: BKS-V1 not found
+# at junit.framework.Assert.fail(Assert.java:57)
+# at junit.framework.TestCase.fail(TestCase.java:223)
+# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
+#
+# 1) testJCE(org.bouncycastle.jce.provider.test.SimpleTestTest)
+# junit.framework.AssertionFailedError: index 9 BlockCipher: IDEA/PGPCFB/NoPadding failed encryption - java.io.IOException: javax.crypto.ShortBufferException: output buffer too short for input.
+# at junit.framework.Assert.fail(Assert.java:57)
+# at junit.framework.TestCase.fail(TestCase.java:223)
+# at org.bouncycastle.jce.provider.test.SimpleTestTest.testJCE(SimpleTestTest.java:26)
+JAVA_TEST_RUN_ONLY=(
+ "org.bouncycastle.asn1.test.AllTests"
+ "org.bouncycastle.crypto.agreement.test.AllTests"
+ "org.bouncycastle.crypto.ec.test.AllTests"
+ "org.bouncycastle.crypto.prng.test.AllTests"
+ "org.bouncycastle.crypto.test.AllTests"
+ "org.bouncycastle.jcajce.provider.test.AllTests"
+# "org.bouncycastle.jce.provider.test.AllTests" # bug #827146
+ "org.bouncycastle.jce.provider.test.nist.AllTests"
+ "org.bouncycastle.jce.provider.test.rsa3.AllTests"
+ "org.bouncycastle.pqc.crypto.lms.AllTests"
+ "org.bouncycastle.pqc.crypto.test.AllTests"
+ "org.bouncycastle.pqc.jcajce.provider.test.AllTests"
+ "org.bouncycastle.util.encoders.test.AllTests"
+)
+
+check_env() {
+ if use test; then
+ # this is needed only for tests
+ CHECKREQS_MEMORY="2048M"
+ check-reqs_pkg_pretend
+ fi
+}
+
+pkg_pretend() {
+ check_env
+}
+
+pkg_setup() {
+ check_env
+}
+
+src_prepare() {
+ default
+ java-pkg_clean ..
+}
+
+src_test() {
+ JAVA_TEST_EXTRA_ARGS+=" -Xmx${CHECKREQS_MEMORY}"
+ java-pkg-simple_src_test
+}
+
+src_install() {
+ default
+ einstalldocs
+ docinto html
+ dodoc -r ../docs
+
+ # These files are not present in the upstream jar but are used for tests
+ # Removing them from the jar file after testing
+ zip --delete "${S}"/bcprov.jar \
+ "org/bouncycastle/pqc/crypto/ntru/*" \
+ "org/bouncycastle/pqc/math/ntru/*" \
+ || die "cleaning after tests failed"
+
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/bcprov/metadata.xml b/dev-java/bcprov/metadata.xml
index b5ad9ebd01ee..1a34130e2c63 100644
--- a/dev-java/bcprov/metadata.xml
+++ b/dev-java/bcprov/metadata.xml
@@ -6,6 +6,6 @@
<name>Java</name>
</maintainer>
<longdescription>
- "The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.5 to JDK 1.8."
+ The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.8 and up.
</longdescription>
</pkgmetadata>