summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/charva/charva-1.1.4-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/charva/charva-1.1.4-r1.ebuild')
-rw-r--r--dev-java/charva/charva-1.1.4-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/charva/charva-1.1.4-r1.ebuild b/dev-java/charva/charva-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..8c7dd2f2ecf1
--- /dev/null
+++ b/dev-java/charva/charva-1.1.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+JAVA_PKG_IUSE="doc examples source"
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit eutils java-pkg-2 java-ant-2 toolchain-funcs
+
+DESCRIPTION="A Java Windowing Toolkit for Text Terminals"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}/charva.zip -> ${P}.zip"
+HOMEPAGE="http://www.pitman.co.za/projects/charva/"
+RDEPEND=">=virtual/jre-1.5
+ sys-libs/ncurses
+ dev-java/commons-logging:0"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${RDEPEND}"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PN}-respect-flags.patch
+
+ rm -v ./c/lib/*.so || die
+ rm -v java/lib/* || die
+ rm -v java/dist/lib/* || die
+ find . -name "*.class" -print -delete || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-logging"
+EANT_BUILD_TARGET="dist"
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd c/src
+ emake CC="$(tc-getCC)" INCLUDES="$(java-pkg_get-jni-cflags)" -f Makefile.linux.txt
+}
+
+src_install() {
+ java-pkg_dojar ./java/dist/lib/charva.jar
+ use doc && java-pkg_dojavadoc docs/api
+ use examples && java-pkg_doexamples test/src/example
+ use source && java-pkg_dosrc java/src/{charva,charvax}
+
+ java-pkg_doso c/lib/*.so
+}