summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-11 13:58:03 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-11 14:08:45 +0000
commit5cde0e3b1a65da4a78d315c45740f3af5aeb1261 (patch)
tree1fa26ed849e9e42dd74b1de17a6659d54a1b5175 /dev-java/cofoja/cofoja-1.2.ebuild
parentdev-java/netty-common: Remove old version. (diff)
downloadgentoo-5cde0e3b1a65da4a78d315c45740f3af5aeb1261.tar.gz
gentoo-5cde0e3b1a65da4a78d315c45740f3af5aeb1261.tar.bz2
gentoo-5cde0e3b1a65da4a78d315c45740f3af5aeb1261.zip
dev-java/cofoja: Version bump. Fixes bug 557294.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/cofoja/cofoja-1.2.ebuild')
-rw-r--r--dev-java/cofoja/cofoja-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/cofoja/cofoja-1.2.ebuild b/dev-java/cofoja/cofoja-1.2.ebuild
new file mode 100644
index 000000000000..da416abe74e8
--- /dev/null
+++ b/dev-java/cofoja/cofoja-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Contracts for Java"
+HOMEPAGE="https://code.google.com/p/cofoja/"
+SRC_URI="https://github.com/nhatminhle/${PN}/archive/v${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+CDEPEND="dev-java/asm:4"
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="asm-4"
+JAVA_SRC_DIR="src/com/google/java/contract"
+
+# Relies on a bunch of classes in jsr308,
+# spec we don't have packaged in Gentoo.. yet.
+JAVA_RM_FILES=(
+ src/com/google/java/contract/core/apt/JavacUtils.java
+)