summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-17 14:46:13 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-07-17 15:22:13 +0200
commite91be99cf298deee51b1b5a071dd414dcb4c44ed (patch)
tree7b184b73806a5106d43811eb37bc268aa3b540d7 /dev-java/commons-compress/commons-compress-1.10.ebuild
parentdev-java/xml-commons-external: Stable for amd64. Retroactively mark stable fo... (diff)
downloadgentoo-e91be99cf298deee51b1b5a071dd414dcb4c44ed.tar.gz
gentoo-e91be99cf298deee51b1b5a071dd414dcb4c44ed.tar.bz2
gentoo-e91be99cf298deee51b1b5a071dd414dcb4c44ed.zip
dev-java/commons-compress: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-java/commons-compress/commons-compress-1.10.ebuild')
-rw-r--r--dev-java/commons-compress/commons-compress-1.10.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-java/commons-compress/commons-compress-1.10.ebuild b/dev-java/commons-compress/commons-compress-1.10.ebuild
index 53223291a330..a6326c38ccd2 100644
--- a/dev-java/commons-compress/commons-compress-1.10.ebuild
+++ b/dev-java/commons-compress/commons-compress-1.10.ebuild
@@ -1,25 +1,29 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
+
JAVA_PKG_IUSE="doc source test"
inherit java-pkg-2 java-ant-2
-DESCRIPTION="Commons Compress defines an API for working with ar, cpio, tar, zip, gzip and bzip2 files"
+DESCRIPTION="Java API for working with archive files"
HOMEPAGE="https://commons.apache.org/proper/commons-compress/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
CDEPEND="dev-java/xz-java:0"
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.6
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
${CDEPEND}
+ >=virtual/jdk-1.6
test? (
dev-java/junit:4
dev-java/ant-junit:0