summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild')
-rw-r--r--dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild b/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild
new file mode 100644
index 000000000000..9b2053d295df
--- /dev/null
+++ b/dev-java/commons-configuration/commons-configuration-1.6-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
+HOMEPAGE="http://commons.apache.org/configuration/"
+SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
+
+# it needs functionality from ant-core, although not providing an ant task
+# the functionality is apparently needed only for 1.4 jdk
+# but I don't feel like adding virtual for this
+CDEPEND="
+ >=dev-java/commons-beanutils-1.7.0:1.7
+ >=dev-java/commons-codec-1.3:0
+ >=dev-java/commons-collections-3.1:0
+ >=dev-java/commons-digester-1.8:0
+ >=dev-java/commons-jxpath-1.2:0
+ >=dev-java/commons-lang-2.4:2.1
+ >=dev-java/commons-logging-1.1.1:0
+ java-virtuals/servlet-api:3.0
+ dev-java/ant-core:0"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ # Tweak build classpath and don't automatically run tests
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7
+ commons-codec
+ commons-collections
+ commons-digester
+ commons-jxpath
+ commons-lang-2.1
+ commons-logging
+ servlet-api-3.0
+ ant-core"
+
+# Would need mockobjects with j2ee support which we don't have
+# Check overlay for ebuild with test support
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+ dodoc RELEASE-NOTES.txt || die
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}